[sane-devel] Canon630u: scanimage: sane_start: Device busy

Andrew Kovacs atkova@isa.mim.com.au
Wed, 15 Jan 2003 18:46:32 +1000


Hi Greg,
I was just shutting down and heading home when I saw your message.  I've
only had a quick glance, and not read with any detail (I'm late for a dance
class) but it looks similar to my system's problem.
I had the same problem, tried all I'd seen in the list and still no go.
Eventually Henning suggested I contact Nathan Rutman [nthn1@yahoo.com], the
author of the canon630u backend.  
I did so and Nathan suggested I delete the /tmp/canon.cal file, as this can
cause sane to tie up the scanner (or something like that).  I tried it and
it worked.  It creates another error message, but I'll chase that up later,
and Nathan thinks that this problem will be fixed in the next release of
sane.
I am going to write a bit of a blurb and post it, so anyone else can follow
all the steps (just basic, not exhaustive like the USB one that's just been
done).  
I hope this helps.

Before I forget, and I've been remiss in not mentioning this earlier, thanks
to Henning and Nathan for their time and efforts in solving my system's
problem.

-----Original Message-----
From: Greg Kubaczkowski [mailto:greg.kubaczkowski@utoronto.ca]
Sent: Wednesday, 15 January 2003 15:10
To: SANE Mailing List
Subject: [sane-devel] Canon630u: scanimage: sane_start: Device busy


Hi all

I hoping someone has seen a similar problem and found a solution for it.  I
have seen some posting on the subject, but could not find any answers that
would work for me...

I have a RedHat 8.0, sane 1.0.8 (tried with 1.0.9 - same result) and
Canon630u.  The system recognizes my scanner, but scanimage -d
canon630u:/dev/usb/scanner0 results in Device busy error.

At certain point it actually worked!  I used xsane and was able to scan an
image. After reboot I could not get it to work anymore...

Here is some more info:

/etc/sane.d/canon630u:
# Options for the canonusb backend
# Autodetect the Canon CanoScan FB630u
#usb 0x04a9 0x2204
/dev/usb/scanner0
# device list for non-linux-systems (enable if autodetect fails):
#/dev/scanner
#/dev/usb/scanner0

/etc/modules.conf:
alias char-major-81 scanner
options scanner vendor=0x4a9 product=0x2204

sane-find-scanner:
# Note that sane-find-scanner will find any scanner that is connected
# to a SCSI bus and some scanners that are connected to the Universal
# Serial Bus (USB) depending on your OS. It will even find scanners
# that are not supported at all by SANE. It won't find a scanner that
# is connected to a parallel or proprietary port.

sane-find-scanner: found USB scanner (vendor = 0x04a9, product = 0x2204) at
device /dev/usb/scanner0
sane-find-scanner: found USB scanner (vendor = 0x04a9, product = 0x2204) at
device /dev/usbscanner0


scanimage -L:
device `canon630u:/dev/usb/scanner0' is a CANON Canoscan FB630U flatbed
scanner

scanimage -d canon630u:/dev/usb/scanner0
scanimage: sane_start: Device busy

Any help would be greatly appreciated.

Thanks,

Greg.

Regards,
Andrew Kovacs


**********************************************************************
The information contained in this e-mail is confidential and is
intended only for the use of the addressee(s).
If you receive this e-mail in error, any use, distribution or
copying of this e-mail is not permitted. You are requested to
forward unwanted e-mail and address any problems to the
MIM Holdings Limited Support Centre.
For general enquires:	++61 7 3833 8000
Support Centre e-mail:	supportcentre@mim.com.au
Support Centre phone:  	Australia 1800500646
        				International ++61 7 38338042
**********************************************************************