Rep:Re: [sane-devel] Access to the ressource has been denied

Henning Meier-Geinitz
Mon, 7 Jul 2003 14:55:50 +0200


On Sun, Jul 06, 2003 at 11:07:01PM +0000, wrote:
> >> to the resource has been denied. 
> >Usually you get debug messages by setting
> >in your case try
> >SANE_DEBUG_PRIMAX=255 scanimage --lamp-on
> Ok, I did it, but this gives no other results (it
> still only prints the error message). I tried
> SANE_DEBUG_DLL and I've got something there. But IMHO
> nothing seemed strange. I can send the results if
> someone wants me to do so.

You are right. The promax backend doesn't seem to have any debug

> >>It's only since I've upgraded to 9.1 that
> >> this happens.
> >What has changed between these versions? Kernel
> and/or the >version of the primax backend?
> Maybe the kernel, but I'm not sure. If there was a
> change it was a minor one. The backend did certainly
> not change.

Does the command line program work (primax_scan)?

Have you changed the settings of your parallel port, e.g. ECP to EPP
in the BIOS? Or added a printer?

> >> Connnecting via saned changes nothing.
> >> Off course I tried to connect as root, to chmod
> 777
> >> on /dev/lp0,
> >That's the device for the printer, not the parallel
> port.
> scanimage -L shows me this, so I assume it's right
> what I'm doing. Anyway it worked before like this.

Ok. Usually /dev/lp0 is the pronter and /dev/parport is the raw
parallel port or /dev/port if the ppdev module is not loaded. But I'm
neither a parport expert nor I know the primax backend so maybe
/dev/lp0 is right.

> >Maybe the backend doesn't like that you have the
> ppdev >module loaded?
> Sorry, I'm not an expert. Could you explain this to
> me?

I don't know exactly, how the primax backend accesses the parallel
port. There are some ways to do that: 

1) Using assembler (inb, outb) and access the raw port directly
2) Using /dev/port

These two need root permissions

3) Using /dev/parport0

I think using that way you don't need root permissions but the kernel
must have the ppdev driver (modprobe ppdev).

So maybe you get trouble when you mix these methods.

If you don't find details in the docu, try to contact the authors of
the promax backend. I'm not sure if they read this list.