[sane-devel] Fujitsu fi-4220C problems

m. allan noah anoah@pfeiffer.edu
Thu, 31 Jul 2003 09:10:48 -0400 (EDT)

peter, i am actively looking at this. it may be a bug in the fujitsu 
backend, as we dont currently send exactly the same data as a windows 
machine does. i should have an updated version of the backend in a 
couple days. would you (or anyone else) mind testing the patch for me?


On Thu, 31 Jul 2003, Peter Hartshorn wrote:

> Hello all,
> I have revieved a Fujitsu fi-4220C scanner and I am having problems scanning.
> I can sucessfully scan several pages with scanimage but sometimes (quite often)
> I receive the following error
> usb_control/bulk_msg: timeout
> after about a minute the scan will continue as normal.
> I have tried with standard RedHat 8.1 and 9 using sane-backends 1.0.12
> I have also tried using libusb which gives me the error:
> usb_control/bulk_msg: timeout
> usbdevfs: USBDEVFS_BULK failed dev 2 ep 0x81 len 13 ret -110
>                                                  ^^
> 						 ||
> 					(some times 13 is 96)
> Any help would be greatly appreciated.
> I have also tried scanning with a gt68xx scanner (Mustek 1200 UB plus) with no
> errors. So this leads me to think that it is in fact a bug in the fujitsu
> driver for sane.
> >From Peter Hartshorn
> peter@dimtech.com.au
> _______________________________________________
> Sane-devel mailing list
> Sane-devel@www.mostang.com
> http://www.mostang.com/mailman/listinfo/sane-devel

"so don't tell us it can't be done, putting down what you don't know.
money isn't our god, integrity will free our souls" - Max Cavalera