[sane-devel] messed up HP6350 USB Scanje config?

Reid Vail rsv869@adelphia.net
Thu, 05 Jun 2003 23:53:02 -0400

About six months ago Peter gave me some advice about my HP6350c 
scanner.  It fixed my issue and got it working.  (I included that 
exchange at the bottom of this message).  Recently I upgraded my Suse 
box to Suse 8.2 and it's not working again.  I dug out the mail and 
checked the config.  Looks OK to me, and I included a few scraps.   I've 
included the output from sane-find-scanner.  The permissions also look 
OK, too, I think.  Any suggestions would be great.




  # No SCSI scanners found. If you expected something different, make 
sure that
  # you have loaded a SCSI driver for your SCSI adapter.

found USB scanner (vendor=0x03f0, product=0x0601) at libusb:001:002
  # A USB device was detected. This program can't be sure if it's really
  # a scanner. If it is your scanner, it may or may not be supported by
  # SANE. Try scanimage -L and read the backend's manpage.

  # Scanners connected to the parallel port or other proprietary ports 
can't be
  # detected by this program.

  # You may want to run this program as root to find all devices. Once you
  # found the scanner devices, be sure to adjust access permissions as
  # necessary.

reid@linux:/etc/sane.d> ls -l hp.conf
-rwxrwxrwx    1 root     root          480 2003-06-05 21:14 hp.conf

reid@linux:~> ls -l /etc/sane.d/dll.conf
-rw-rw-rw-    1 root     root          448 2002-12-18 00:16 

# dc210
# dc240
# dc25
# dll
# dmc
# epson
# fujitsu
# leo
# microtek
# microtek2
# mustek_usb
# mustek
# matsushita

reid@linux:/etc/sane.d> more hp.conf
#scsi HP
# Uncomment the following if you have "Error during device I/O" on SCSI
#   option dumb-read
# The usual place for a SCSI-scanner on Linux
# USB-scanners supported by the hp-backend
# HP ScanJet 4100C
usb 0x03f0 0x0101
# HP ScanJet 5200C
usb 0x03f0 0x0401
# HP ScanJet 62X0C
usb 0x03f0 0x0201
# HP ScanJet 63X0C
usb 0x03f0 0x0601
# Uncomment the following if your scanner is connected by USB,
# but you are not using libusb
  option connect-device

Peter Kirchgessner wrote:

> Hi,
> pleae have a look at /etc/sane.d/hp.conf or 
> /usr/local/etc/sane.d/hp.conf. It must have two lines in it:
> /dev/usbscanner
>   option connect-device
> In dll.conf (same directories) the line with "hp" must be active.
> You may need to set the permissions:
> chmod 666 /dev/usbscanner
> More hints can be found at http://www.kirchgessner.net/sanehpfaq.html
> Sincerely
> Peter
> Reid Vail schrieb:
>> I've been trying for a least a month to get an HP6350c USB Scanjet to 
>> work. I'm running a SuSE 8.1 Personal distro, which comes with a SANE 
>> implementation of 1.0.8-47.
>> I think (but can't say for sure) that some part of the install of the 
>> unit (via YAST) isn't working because it doesn't even "test" 
>> correctly.  However YAST does correctly identify it.
>> When I run xscanimage I get this output:
>> [xscanimage] No scanners were identified. If you were expecting 
>> something different, check that the scanner is plugged in, turned on and
>> detected by sane-find-scanner (if appropriate). Please read the 
>> documentation which came with this software (README, FAQ, manpages).
>> But when I run sane-find-scanner I get this output:
>> sane-find-scanner: found USB scanner (vendor = 0x03f0, product = 
>> 0x0601) at device /dev/usb/scanner0
>> sane-find-scanner: found USB scanner (vendor = 0x03f0, product = 
>> 0x0601) at device /dev/usbscanner
>> I make no claims that I'm not missing something obvious!  I just 
>> don't get it.  For what it's worth, I know the unit works because it 
>> runs under Windoze 2K.
>> Thanks in advance.
>> Reid Vail
>> _______________________________________________
>> Sane-devel mailing list
>> Sane-devel@www.mostang.com
>> http://www.mostang.com/mailman/listinfo/sane-devel