[sane-devel] Canon Lide 30 backend

Henning Meier-Geinitz sane-devel@mostang.com
Sun, 8 Jun 2003 17:01:01 +0200


On Sun, Jun 08, 2003 at 10:44:42AM +0000, Michael Rasile wrote:
>  found USB scanner (vendor=0x04a9 produce=0x220e at /dev/usb/scanner0
>                                                  at /dev/usbscanner0

Ok, so the kernel USB scanner driver found it.

> > Which version of sane-backends do you use (scanimage --version)?
> > 
>      backend version 1.0.9

Oh. Are you sure that this version supports your scanner? I can't find
"Lide" on the list of supported scanners for 1.0.9. 1.0.12 is the
current version of sane-backends but 1.0.10 may also work.

But I'm not an plustek expert...

> Thanks very much for your response. I apologize if I sent
> this to the wrong list.

Well, sane-devel is ok. Just don't send your answers to only me,
because on the sane-devel mailing list there are more people (e.g. the
plustek maintainer) who know much more about your scanner and the
plustek backend. That's why I cc to the list again.

> This will be the last time I'll post
> here.I'll monitor sane-devel mailing list and figure it out. Please
> find attached the debug output. If I am sending this to the wrong
> place again, please tell me and I will not do so again.

Just send it to sane-devel@mostang.com. That's the mailing list
address. Not (only) to henning@meier-geinitz.de :-)

> Even though I haven't solved the scanner problem yet, I am learning
> something from this. When it is solved, maybe I can help someone else
> with similar problems.

That's very good. We need more people like you!

> [plustek] >[usb] 0x04a9 0x220e<

Ok, that should be your scanner.

> [plustek] next device is a USB device (0x04A9-0x220E)
> [plustek] next device is an USB device
> [plustek] ># - device devicename<
> [plustek] ># i.e. for Plustek (0x07B3) UT12/16/24 (0x0017)<
> [plustek] ># [usb] 0x07B3 0x0017<
> [plustek] >device /dev/usbscanner0<
> [plustek] Decoding device name >/dev/usbscanner0<


> [plustek] attach (/dev/usbscanner0, 0xbfffd170, (nil))
> [plustek] Device configuration:
> [plustek] device name  : >/dev/usbscanner0<
> [plustek] porttype     : 1
> [plustek] USB-ID       : >0x04A9-0x220E<


> [plustek] usbDev_open(/dev/usbscanner0,0x04A9-0x220E)
> [plustek] Vendor ID=0x04A9, Product ID=0x220E
> [plustek] Device >0x04A9-0x220E<, is not supported!

Looks like your backend is really too old.