SV: [sane-devel] sane-find-scanner can find my scanner, but Xsane can't?

Christoffer Holm Kj°lbŠk christoffer@kjoelbaek.dk
Sat, 28 Jun 2003 19:29:55 +0200


-----Oprindelig meddelelse-----
Fra: Michael Rasile [mailto:keeper@neo.rr.com]
Sendt: 28. juni 2003 19:01
Til: Christoffer Holm Kj°lbŠk
Emne: Re: [sane-devel] sane-find-scanner can find my scanner, but Xsane
can't?
Hey Mike

Thanks for you answer

I think the problem is the old backend, that came with RedHat 9.0 as
default.

The version was: 1.0.9-5

Amd the newest is 1.0.12, so maybe it is that

Can i just install the new backend, and nothing else?

regards
Christoffer

On Sat Jun 28, 2003 at 03:23:08PM +0200 or thereabouts, Christoffer Holm
Kj?lb?k wrote:
> Hey
>
> I have a Canon LiDe30, wich shuold be supported by sane
>
> And if I run sane-find-scanner, it finds the scanner at /dev/usb/scanner0
>
> But, Xsane says, that there is no devices available, why?
>
> Kind regards - and thanks in adance
> Christoffer Kj°lbŠk
>
> _______________________________________________
> Sane-devel mailing list
> Sane-devel@www.mostang.com
> http://www.mostang.com/mailman/listinfo/sane-devel
Greetings!
Well, I have the same scanner and I use Gentoo. The first time I installed
gentoo, I couldn't get the scanner to work right away. The problem is the
sane-backend. Do you know what version of sane you have. What does
scanimage -L show? If it doesn't show anything and your scanner is found by
the kernel, then the problem lies with sane's backend. If you upgrade to the
latest version of the sane-backend, it should solve the problem. What I did
was to download the backend from the website and follow the directions for
unpacking and installing. I installed right over the backend that was
installed by gentoo. It worked for me. Now, here is something strange. I had
to reinstall gentoo and before I upgraded the sane-backend, I tried xsane
and it worked. Who knows why? Well, if you upgrade your sane-backend, it
should solve the problem. HTH
--
Regards,
Mike
keeper@neo.rr.com
"Don't Fear The Penguin."