[sane-devel] Genius Vivid-3xe

Michael Fleming mfleming@michaelfleming.webcentral.com.au
Mon, 30 Jun 2003 20:47:42 +1000

On Mon, Jun 30, 2003 at 08:44:43AM +0000, Renito 73 waffled thusly:
> I have troubles to use my Genius Vivid-3xe scanner... sane recognizes it, 
> but applications don't use it... my usb configuration is working properly 
> since I took pictures with my webcam... I did chmod rwxrwxrwx 
> /dev/usb/scanner* since only root had access to the devices... my usb 
> driver is usb-uhcii.o (the other one uhci.o worked fine but my vmware did 
> not work with it, so I changed to usb-uhci.o instead but camera and vmware 
> continued working fine...
> Background:

Let's compare notes - I've got the same model and make working fine,
even for regular users.
(Redhat 9.0, sane-backends 1.0.12, kernel 2.4.20-18.9 (RH Errata vendor

> reno@voodoo:~$ sane-config --version
> 1.0.12

defender:~:$ sane-config --version

> reno@voodoo:~$ sane-find-scanner
> found USB scanner (vendor=0x0458, product=0x2017) at libusb:001:004 (3xe)
> found USB scanner (vendor=0x046d, product=0x0840) at libusb:001:002 (webcam)

defender:~:$ sane-find-scanner | grep ^found
found USB scanner (vendor=0x0458, product=0x2017 [600dpi USB Scanner])
at libusb:001:002

> reno@voodoo:~$ scanimage -L
> device `gt68xx:/dev/usb/scanner0' is a Genius Colorpage Vivid3xe flatbed 
> scanner

I'm not using the scanner.o module, never had much luck with it. libusb
0.1.6 works well enough for me.

defender:~:$ scanimage -L
device `gt68xx:libusb:001:002' is a Genius Colorpage Vivid3xe flatbed

> but when running xsane or kooka they say scanner is not round... what could 
> be the problem? I created this script to load the scanner.o module
> modprobe scanner vendor=0x0458 product=0x2017

Have you tried actually scanning an image? I really don't see any
permissions or access related problems. (I had to remount my
/proc/bus/usb devmode=0666 to enable user access, but that might be a
Redhat-only issue. YMMV.). You can at least find the scanner as a user,
which is encouraging.

What happens when you run "scanimage > out.pnm"?

> got vendor and product from KDE Info Center (USB devices)...
> what could be wrong?

Do you see lots of "bulk_timeout"-like messages among your syslog
entries when you try and scan or run xsane/kooka?

There was a small patch for the gt68xx backend back in late April that
addressed a USB timeout issue (it saw the scanner but subsequent
operations seemed to overwhelm the USB bus on many systems).

Check the archives for this, apply and recompile if you haven't got it.
It worked spectacularly well for me.

> thanx for your help! :)

Michael Fleming.

(PS Henning, the colour handling/matching on this backend and the Genius
Vivid3XE seems to be OK in my tests/experience, I'll put some more
examples if you wish)

Michael Fleming <mfleming@michaelfleming.webcentral.com.au>
"Bother" said the Borg, "We've assimilated Pooh!"