[sane-devel] (No Subject)

Barton Bosch barton_bosch at eudoramail.com
Fri Sep 26 06:32:25 BST 2003

Thanks for the help, I did some more testing and hunting around but still no success.  I have some more info and questions below.


--------- Original Message ---------

DATE: Thu, 25 Sep 2003 22:58:40
From: abel deuring <adeuring at gmx.net>
To: barton_bosch at eudoramail.com
Cc: sane-devel at lists.alioth.debian.org

>Barton Bosch schrieb:
>> I am using  a new Planet CCRMA installation of Red Hat 
>> 8.0 and I am trying to get my scanner up and running, but sane is not recognizing it.   I've never had the all of the bugs ironed out of this set up, but on a 
>> prior installation of a vanilla distribution of Red Hat 8.0 I did have this scanner installed, recognized by sane, and managed to scan one document, so I know that it is possible for this hardware to function under Linux.  
>> scsi1 : Future Domain 16-bit SCSI Driver Version 5.50
>>   Vendor: UMAX      Model: Vista-S6E         Rev: V1.6
>>   Type:   Scanner                            ANSI SCSI revision: 02
>the SCSI system detects the scanner.


>> ohci1394: pci_module_init failed
>That's related to Firewire stuff; it probably does affects ypur scanner 

I'm sorry, could you clarify your meaning here?  1394 is the tip off that it is firewire related, but are you saying that this module failure does or does not affect my scanner situation?  I was assuming that it would not but was puzzled that it popped up at all, seeing as how there is no firewire port on my computer.

>> Checking further, I found that /dev/scanner was a link to /dev/sgb, and /dev/sgb was  a link to /sg1 (not /dev/sg1).  I tried changing /dev/sgb into a 
>symlink to /dev/sg1, but xsane still pops up a dialog box with "xsane: 
>no devices available".
>If /dev/sgb pointed to /sg1, that was indeed an error.
>> All the other /dev/sg* files had permissions of 660 but my original /dev/sg1 had permissions of 600, which I changed to 660.  
>Don't forget to look, which group is set for /dev/sg1. Generally, 
>ordinary users don't belong to the group assigned to SG device files.

The permission was barton (my user account name) and root (as the group owner).  All of the other /sg* files had permissions of root(for user) and disk (as group).  The barton account is not a member of the root group.  Would this cause the scanner to not be found by xsane?  I'll test this tomorrow.


>A possible reason is that the sg module is not loaded. Try a "modprobe sg"

Ok, I'll give that a shot tomorrow as well.

Here are the new questions and the additional background info.

This is a scanner that I bought at a thrift store, so I do not know what kind of shape it is in.  I did manage to scan one document on my previous Red Hat installation right after I got the scanner.  As I remember, without using a terminator, and with the scsi id switch set to 7, I plugged it into the SCSI card and booted the system -- the scsi host adapter card recognized 7 instances of the scanner, and I configured them all in Kudzu, the Red Hat autoconfiguration lizard.  

I opened xsane from the start menu and the scanner was recognized without a problem.  I scanned a handwritten document as a test, and it was far too light, basically illegible.  I have never done any scanning before and it was my first time using xsane, so I started experimenting with the settings, etc., and tried to do another scan, but xsane crashed on me, or otherwise crapped out.  When I tried to restart it, the scanner was no longer recognized by xsane. 

BTW, today I tested it with the scsi id settings of 1 and 7, and used what I hope is a terminator, but it is unlableled and is also a used thrift store find, and may be some sort of other male D 25 connector scsi terminator look-alike piece of hardware for all I know.  I don't have any way of testing it other than on this scanner...  I did test the set up without the terminator in question, but that didn't work either.

At the time I assumed that I had tweaked the settings in some way and messed things up.  I started in to reading the sane web site docs more thoroughly, and saw that there was a long section on setting up and configuring the software.  Not having the time to sit down and spend a day or two putting my scanner on a firm foundation and knowing that it basically worked, I put it aside until now... 

Two possibilities occur to me:  1) Is it possible that I did something while experimenting with the various settings in xsane that damaged the scanner somehow so that it is no longer recognized?  E.g., tripped something in the firmware or did something else that is causing the problem?;  and, 2)  Maybe the thing just broke... I got it home from the store and it had one or two scans left in it and then some circuit just died.

This afternoon I tried to get it up and running under Windows 98, and with various hassles finding driver files on the net and getting it configured under W98 --which I eventually managed to do.  But I find the same situation with a different W98.  

The scsi host adapter sees the scanner with the correct vendor label, I have it configured so that it is "functioning properly" and there are no resource conflicts under the hardware manager, but when I call up the test utility or the Vista Scan interface, they search for UMAX scanners and come up empty.  This is why I suspect firmware or hardware problems.  

Under both Linux and W98 the scanner poweres up, does its little self test, is recognized by the host adapter and the OS, but when it comes to doing a scan, the scanning applications don't see any scanner.  

Does anyone recognize these symptoms or have any helpful suggestions or (better still) solutions? 



Need a new email address that people can remember
Check out the new EudoraMail at

More information about the sane-devel mailing list