[sane-devel] (No Subject)

Henning Meier-Geinitz henning at meier-geinitz.de
Fri Sep 26 12:18:37 BST 2003


On Thu, Sep 25, 2003 at 10:32:25PM -0700, Barton Bosch wrote:
> >That's related to Firewire stuff; it probably does affects ypur scanner 
> >problem.
> I'm sorry, could you clarify your meaning here?

I'm not Abel but I guess he meant "does not affect".

> The permission was barton (my user account name) and root (as the
> group owner).  All of the other /sg* files had permissions of
> root(for user) and disk (as group).  The barton account is not a
> member of the root group.  Would this cause the scanner to not be
> found by xsane?  I'll test this tomorrow.

If the file is owned by you and the user has read/write permissions
that should work.

> This is a scanner that I bought at a thrift store, so I do not know
> what kind of shape it is in.  I did manage to scan one document on my
> previous Red Hat installation right after I got the scanner.  As I
> remember, without using a terminator, and with the scsi id switch set
> to 7, I plugged it into the SCSI card and booted the system -- the
> scsi host adapter card recognized 7 instances of the scanner, and I
> configured them all in Kudzu, the Red Hat autoconfiguration lizard.  

That sounds bad. Usually the SCSI id of the scanner doesn't matter.
Just make sure that it's different from the id of the SCSI host
controller. I can't comment on this specific scanner but usually
termination is not critical at least if you only have connected one
device. There may be exceptions, however.

> I opened xsane from the start menu and the scanner was recognized
> without a problem.  I scanned a handwritten document as a test, and
> it was far too light, basically illegible.  I have never done any
> scanning before and it was my first time using xsane, so I started
> experimenting with the settings, etc., and tried to do another scan,
> but xsane crashed on me, or otherwise crapped out.  When I tried to
> restart it, the scanner was no longer recognized by xsane. 

There are several possible reasons: harbware related (termination,
cable), driver realted (bad Linux SCSI driver?) or SANE-related
(backends sneds bad commands and confuses the scanner).

> BTW, today I tested it with the scsi id settings of 1 and 7, and used
> what I hope is a terminator, but it is unlableled and is also a used
> thrift store find, and may be some sort of other male D 25 connector
> scsi terminator look-alike piece of hardware for all I know.  I don't
> have any way of testing it other than on this scanner...  I did test
> the set up without the terminator in question, but that didn't work
> either.

I don't think that the detection problem is termination related. The
scanner is detected by the kernel, just not by sane-find-scanner.
Check the idescsi issue and try as root (see my other posting).

> At the time I assumed that I had tweaked the settings in some way and
> messed things up.  I started in to reading the sane web site docs
> more thoroughly, and saw that there was a long section on setting up
> and configuring the software.  Not having the time to sit down and
> spend a day or two putting my scanner on a firm foundation and
> knowing that it basically worked, I put it aside until now... 

sane-find-scanner should find your scanner even if you changed all
settings in xsane and the backend configuration file.

> Two possibilities occur to me: 1) Is it possible that I did something
> while experimenting with the various settings in xsane that damaged
> the scanner somehow so that it is no longer recognized?  E.g.,
> tripped something in the firmware or did something else that is
> causing the problem?;

Possible but extremely unlikely. I have (nearly) destroyed a scanner
when experimenting with the source code of SANE but this was a
mechanical problem and not a firmware issue. The scanner was still
recognized but the scan head was displaced. So I don't think it's the
issue especially as it's detected by the kernel.

> and, 2) Maybe the thing just broke... I got it
> home from the store and it had one or two scans left in it and then
> some circuit just died.

Possible but also unlikely in my experience.

> The scsi host adapter sees the scanner with the correct vendor label,
> I have it configured so that it is "functioning properly" and there
> are no resource conflicts under the hardware manager, but when I call
> up the test utility or the Vista Scan interface, they search for UMAX
> scanners and come up empty.  This is why I suspect firmware or
> hardware problems.  

Ok this is more plausible. But as I have seen all my scanners failing
to be detected on Win98 from time to time I wouldn't trust that.

> Under both Linux and W98 the scanner poweres up, does its little self
> test, is recognized by the host adapter and the OS, but when it comes
> to doing a scan, the scanning applications don't see any scanner.  

If the kernels finds it, sane-find-scanner should also find it.


More information about the sane-devel mailing list