[sane-devel] Relatively no-brainer installation instructions: SANE/Epson 2400

Karl Heinz Kremer khk@khk.net
Sat, 28 Aug 2004 08:17:32 -0400

[ I cc'ed the sane-devel list ]

You don't need a krenel driver for scanners anymore when you use the 
system. That's the reason why /proc/bus/usb/devices does show "none". 
OK, and my system does the same.

Did you compile Sane yourself? Then the configuration file may be in
/usr/local/etc/sane.d/ and not in /etc/sane.d. However, it's important
that you only have one Sane version on your system. If Sane was 
with FC2, and you also compiled it from sources, you will have two 
and this can and will cause problems with scanners not working.

Karl Heinz

On Aug 28, 2004, at 3:23 AM, Steven P. Ulrick wrote:

> On Fri, 27 Aug 2004 19:09:11 -0400
> Karl Heinz Kremer <khk@khk.net> wrote:
>> Fedora Core 2 is using a 2.6.x kernel, which does no longer support
>> the scanner kernel module. You need to use libusb (which is
>> installed). What you need to do in order to make this scanner work is
>> add this line to the /etc/sane.d/epson.conf file:
>> usb
>> Assuming the hotplug system is setup correctly in Fedora Core 2, it
>> should just work. If not, you may have to configure hotplugging.
>> You should however be able to scan as root user.
>> Karl Heinz
> Hello, Karl :)
> Thank you for your response.  Unfortunately, I'm still stuck in the 
> same
> place I was when I wrote my original email on this.  I can't even scan
> as root.
> One potentially relevant detail: cat /proc/bus/usb/devices ouputs the
> following:
> T:  Bus=01 Lev=01 Prnt=01 Port=05 Cnt=02 Dev#=  6 Spd=480 MxCh= 0
> D:  Ver= 2.00 Cls=ff(vend.) Sub=ff Prot=ff MxPS=64 #Cfgs=  1
> P:  Vendor=04b8 ProdID=011b Rev= 1.00
> S:  Manufacturer=EPSON
> S:  Product=EPSON Scanner
> C:* #Ifs= 1 Cfg#= 1 Atr=c0 MxPwr=  2mA
> I:  If#= 0 Alt= 0 #EPs= 2 Cls=ff(vend.) Sub=ff Prot=ff Driver=(none)
> E:  Ad=81(I) Atr=02(Bulk) MxPS= 512 Ivl=0ms
> E:  Ad=02(O) Atr=02(Bulk) MxPS= 512 Ivl=0ms
> You will notice that it says that there is no driver.
> One thing I need to mention.  I did have Epson's IScan installed when I
> first hooked up the scanner.  I did successfully scan a few pictures,
> some of quite a high resolution.  When I uninstalled Iscan, and I tried
> to go strictly with SANE, no joy.  I tried reinstalling iscan, and now 
> I
> can't even scan with that installed.  To clarify, I didn't actually use
> iscan to scan, I used a KDE application called Kooka.  Now Kooka 
> doesn't
> detect any scanners.
> Even when Kooka detected the scanner, no other applications detected 
> it:
> OpenOffice.org, The GIMP.
> If there is anything else I need to mention, please let me know.  I 
> that the scanner works, and that it works on this system.
> Have a Great Day :)
> Steven P. Ulrick