[sane-devel] Canon F2700 on FreeBSD 5.3 AMD64

Bram Van Steenlandt brampie@no-wackos.com
Mon, 13 Dec 2004 21:00:00 +0100

Hi all

I already changed /dev/scanner to /dev/pass0 so this was not the 
problem, I did all scanning as root so the problem couldn't be there either.

I replaced the canon parts in sane/backend with the one you sent me and 
wow, it all of the suddenly worked.

One strange thing, when I start xscanimage the default is set to slides.
Slides is what I am scanning so I do not tough anything and push scan 
(340 dpi)
The scan worked but he was using the colors of negatives.

I then changed it to negatives, scanned on 2720 dpi and all worked well, 
when I then wanted to scan an slide and changed it back to slides the 
colors are OK ????

speed seemed ok (but I've never used windows so I have no way off 

Just one last thing, with my first scan I forget to insert a slide.
I then had to kill the app because it seemed to me that nothing happend. 
The scanner refused to scan untill I rebooted (this was in terminal with 
scanimage so you can't push cancel)

Thanks a bunch


mitsuru okaniwa wrote:

> Dear Bram
> Now, Ulrich Deiters have made the new test version (canon-1.13e).
> Would you test them?
> Best regards,
> mitsuru okaniwa
> ----- Original Message ----- From: "Bram Van Steenlandt" 
> <brampie@no-wackos.com>
> To: <sane-devel@lists.alioth.debian.org>
> Sent: Saturday, December 11, 2004 7:00 AM
> Subject: [sane-devel] Canon F2700 on FreeBSD 5.3 AMD64
>> Hi all
>> I have an Canoscan 2700F and I have the following situation:
>> -sane-find-scanner works
>> -scanimage says invalid argument
>> -xscanimage can scan the preview but when you wan't to do the real 
>> scan it also says "sane_start : invalid argument"
>> considering the fact that the preview works I think that everything 
>> is configured as it should.
>> If anybody has ideas or solutions please bring them on.