[sane-devel] Cannot set up an EPSON Perfection 2400 PHOTO

khk@khk.net khk@khk.net
Fri, 9 Jan 2004 07:17:53 -0500 (EST)

The scanner is fully supported with Sane. It is also correctly identified:
The GT-9300 is the internal name of the device. The name "Perfection 2400"
is not stored anywhere in the firmware, it's just printed on the outside.
The Sane backend only sees the internal name, and this is what it reports.
If you change the scanning mode on the commmand line, you will be able
to scan both grayscale and color in addition to the black&white (or
lineart mode).

Is it possible that RH9 unloads the driver if you are not scanning for
a while and has a problem reloading it? This is very likely not a Sane
problem, but a problem with your USB subsystem. I'm not familiar with
RH9, so I'm not in a position to comment on that. Sorry.

Karl Heinz

> I had heard that my EPSON Perfection 2400 scanner was supported by
> SANE.  I plugged it into the USB port on a computer running Red Hat
> Linux 9.0, installed SANE from source, and then ran the
> "sane-find-scanner" program.  I got the following output:
> # sane-find-scanner
>   # No SCSI scanners found. If you expected something different, make sure
> that
>   # you have loaded a SCSI driver for your SCSI adapter.
>   # Also you need support for SCSI Generic (sg) in your operating system.
>   # If using Linux, try "modprobe sg".
> found USB scanner (vendor=0x04b8, product=0x011b) at /dev/usb/scanner0
> found USB scanner (vendor=0x04b8 [EPSON], product=0x011b [EPSON Scanner])
> at libusb:001:002
>   # Your USB scanner was (probably) detected. It may or may not be
> supported by
>   # SANE. Try scanimage -L and read the backend's manpage.
>   # Scanners connected to the parallel port or other proprietary ports
> can't be
>   # detected by this program.
> As the "sane-find-scanner" program suggested, I ran "scanimage -L", and
> got the following:
> # scanimage -L
> No scanners were identified. If you were expecting something different,
> check that the scanner is plugged in, turned on and detected by the
> sane-find-scanner tool (if appropriate). Please read the documentation
> which came with this software (README, FAQ, manpages).
> As the HOWTO suggested, I tried it again:
> # scanimage -L
> device `epson:/dev/usb/scanner0' is a Epson GT-9300 flatbed scanner
> I know that my scanner is NOT an Epson GT-9300!  I seem to be able to
> scan pictures even when the scanner is incorrectly identified, but they
> come out as line art (perhaps this is because I haven't yet looked up
> the EPSON-specific command line options).
> I have commented out every driver listed in /etc/sane.d/dll.conf
> *except* the "epson" driver, to minimize the chance of SANE using the
> wrong driver.  Furthermore, the /etc/sane.d/epson.conf file has every
> line commented out except for:
> usb /dev/usb/scanner0
> I also double-checked that libusb is installed.  I don't have any other
> USB devices connected to the computer, but I am reasonably sure that the
> USB interface itself is properly configured (I wouldn't expect a
> misconfigured USB interface to be able to report that I have an EPSON
> scanner).  I am also sure that the problem does not lie in the
> permissions (I'm using it while logged in as root).
> I have also found that, for some reason, if I leave it and come back a
> few minutes later, SANE will fail to find my scanner.  The
> "sane-find-scanner" command works as before, but "scanimage -L" fails to
> detect a scanner no matter how many times I try it.  If I try to scan
> the image using the command:
> # scanimage -d epson:/dev/usb/scanner0 --format tiff > new.tiff
> I get the following error:
> scanimage: open of device /dev/usb/scanner0 failed: Invalid argument
> According to both the website and the mailing list archives, the EPSON
> Perfection 2400 PHOTO scanner works with SANE, but I cannot figure out
> how.  What am I doing wrong?
> --
> Lincoln Peters <sampln@sbcglobal.net>
> --
> sane-devel mailing list: sane-devel@lists.alioth.debian.org
> http://lists.alioth.debian.org/mailman/listinfo/sane-devel
> Unsubscribe: Send mail with subject "unsubscribe your_password"
>              to sane-devel-request@lists.alioth.debian.org