[sane-devel] Problems with mustek_pp and releasing the parallel port

Jim George jim.george@blueyonder.co.uk
Sat, 10 Jan 2004 20:59:13 -0000 (GMT)

Content-Type: text/plain; charset=iso-8859-1
Content-Transfer-Encoding: 8bit

Hi Eddy,

I do have a printer connected to the same port.  It's an Epson Photo
Stylus 820cxi if that makes any difference.

I tried turning off/on my scanner but that made no difference, then I
rebooted and when I tried again I got the attached (which was the same as
when I had to turn the scanner off/on).

Could it be a simple configuration issue, something like using EPP on the

Anyway please find the SANE?I_PA4S2 output from this aborted attempted

Best Regards,


Content-Type: text/plain; name="sanedonly.txt"
Content-Disposition: attachment; filename="sanedonly.txt"

 /etc/init.d/inetd stop

[saned] main: starting debug mode (level 128)
[saned] main: trying to get port for service `sane' (getaddrinfo)
[saned] main: [0] socket () using IPv6
[saned] main: [0] setsockopt ()
[saned] main: [0] bind () to port 6566
[saned] main: [0] listen ()
[saned] main: [1] socket () using IPv4
[saned] main: [1] setsockopt ()
[saned] main: [1] bind () to port 6566
[saned] main: [1] bind failed: Address already in use
[saned] main: waiting for control connection
[saned] saned (AF-indep+IPv6) from sane-backends 1.0.13 ready
[saned] check_host: access by remote host: ::1
[saned] check_host: remote host is IN6_LOOPBACK: access granted
[saned] init: access granted
[saned] init: access granted to root@::1
[saned] process_request: waiting for request
[saned] process_request: got request 2
[saned] process_request: access to resource `mustek_pp' granted
[sanei_debug] Setting debug level of mustek_pp to 128.
[mustek_pp] sane-mustek_pp, version 0.12-alpha. build for SANE 1.0.13
[mustek_pp] backend by Jochen Eisinger <jochen.eisinger@gmx.net>
[sanei_debug] Setting debug level of sanei_pa4s2 to 255.
[sanei_pa4s2] sanei_pa4s2: interface called for the first time
[sanei_pa4s2] sanei_pa4s2_open: called for device 'parport0'
[sanei_pa4s2] sanei_pa4s2_open: trying to connect to port
[sanei_pa4s2] pa4s2_open: trying to attach dev `parport0`
[sanei_pa4s2] pa4s2_init: static int first_time = 1
[sanei_pa4s2] pa4s2_init: called for the first time
[sanei_pa4s2] pa4s2_init: initializing libieee1284
[sanei_pa4s2] pa4s2_init: 1 ports reported by IEEE 1284 library
[sanei_pa4s2] pa4s2_init: port 0 is `parport0`
[sanei_pa4s2] pa4s2_init: allocating port list
[sanei_pa4s2] pa4s2_init: initialized successfully
[sanei_pa4s2] pa4s2_open: looking up port in list
[sanei_pa4s2] pa4s2_open: port is in list at port[0]
[sanei_pa4s2] pa4s2_open: setting up port data
[sanei_pa4s2] pa4s2_open: name=parport0 in_use=SANE_TRUE
[sanei_pa4s2] pa4s2_open: enabled=SANE_FALSE mode=PA4S2_MODE_NIB
[sanei_pa4s2] pa4s2_open: opening device
[sanei_pa4s2] pa4s2_open: device `parport0` opened...
[sanei_pa4s2] pa4s2_open: returning SANE_STATUS_GOOD
[sanei_pa4s2] pa4s2_open: open dev `parport0` as fd 0
[sanei_pa4s2] sanei_pa4s2_open: connected to device using fd 0
[sanei_pa4s2] sanei_pa4s2_open: checking for scanner
[sanei_pa4s2] sanei_pa4s2_enable: called for fd 0 with value 1
[sanei_pa4s2] sanei_pa4s2_enable: enable port 'parport0'
[sanei_pa4s2] pa4s2_enable: prelock[] = {0x04, 0xd8, 0x0c}
[sanei_pa4s2] sanei_pa4s2_enable: returning SANE_STATUS_GOOD
[sanei_pa4s2] sanei_pa4s2_open: reading ASIC id
[sanei_pa4s2] sanei_pa4s2_readbegin: called for fd 0 and register 0
[sanei_pa4s2] sanei_pa4s2_readbegin: NIB readbegin
[sanei_pa4s2] pa4s2_readbegin_nib: selecting register 0 at 'parport0'
[sanei_pa4s2] sanei_pa4s2_readbegin: returning SANE_STATUS_GOOD
[sanei_pa4s2] sanei_pa4s2_readbyte: called with fd 0
[sanei_pa4s2] sanei_pa4s2_readbyte: we hope, the backend called
[sanei_pa4s2] sanei_pa4s2_readbyte: readbegin, so the port is ok...
[sanei_pa4s2] sanei_pa4s2_readbyte: this means, I did not check it - it's
[sanei_pa4s2] sanei_pa4s2_readbyte: not my fault, if your PC burns down.
[sanei_pa4s2] sanei_pa4s2_readbyte: read in NIB mode
[sanei_pa4s2] pa4s2_readbyte_nib: reading value 0xb5 from 'parport0'
[sanei_pa4s2] sanei_pa4s2_readbyte: read finished
[sanei_pa4s2] sanei_pa4s2_readbyte: got value 0xb5
[sanei_pa4s2] sanei_pa4s2_readbyte: returning SANE_STATUS_GOOD
[sanei_pa4s2] sanei_pa4s2_readend: called for fd 0
[sanei_pa4s2] sanei_pa4s2_readend: we hope, the backend called
[sanei_pa4s2] sanei_pa4s2_readend: readbegin, so the port is ok...
[sanei_pa4s2] sanei_pa4s2_readend: this means, I did not check it - it's
[sanei_pa4s2] sanei_pa4s2_readend: not my fault, if your PC burns down.
[sanei_pa4s2] sanei_pa4s2_readend: NIB mode readend
[sanei_pa4s2] pa4s2_readend_nib: end of reading sequence for fd 0
[sanei_pa4s2] sanei_pa4s2_readend: returning SANE_STATUS_GOOD
[sanei_pa4s2] sanei_pa4s2_open: could not find scanner
[sanei_pa4s2] sanei_pa4s2_open: reported ASIC id 0xb5
[sanei_pa4s2] sanei_pa4s2_enable: called for fd 0 with value 0
[sanei_pa4s2] sanei_pa4s2_enable: disable port 'parport0'
[sanei_pa4s2] pa4s2_disable: state restored
[sanei_pa4s2] sanei_pa4s2_enable: returning SANE_STATUS_GOOD
[sanei_pa4s2] sanei_pa4s2_open: closing port
[sanei_pa4s2] sanei_pa4s2_close: fd = 0
[sanei_pa4s2] sanei_pa4s2_close: freeing resources
[sanei_pa4s2] pa4s2_close: fd=0
[sanei_pa4s2] pa4s2_close: this is port 'parport0'
[sanei_pa4s2] pa4s2_close: checking whether port is enabled
[sanei_pa4s2] pa4s2_close: trying to free io port
[sanei_pa4s2] pa4s2_close: marking port as unused
[sanei_pa4s2] pa4s2_close: returning SANE_STATUS_GOOD
[sanei_pa4s2] sanei_pa4s2_close: finished
[sanei_pa4s2] sanei_pa4s2_open: returning SANE_STATUS_INVAL
[mustek_pp] cis_attach: couldn't attach to `parport0' (Invalid argument)
[mustek_pp] sane_open: unknown devicename ``Mustek-1200CP''
[saned] process_request: waiting for request
[saned] process_request: got request 10
[mustek_pp] sane_exit: all drivers unloaded
[saned] quit: exiting