[sane-devel] Packard Bell 2450 works with gt68xx (and problems)

Hynek Hanke hanke@volny.cz
Tue, 13 Jan 2004 20:44:22 +0100

Hi all,

the Packard Bell Diamond 2450, which you didn't have
any information about if I understand correctly, seems
to work with the gt68xx driver! My girlfriend received
it as a pressent so I had no other choice than to try ;)

I copied the firmvare .usb file from the CD with MS Windows
drivers into the right location, as described in the manpage
to gt68xx. It's normally available on the CD, it's not compressed
in an .exe or something.

Then I uncommented gt68xx in /etc/sane.d/dll.conf.

Now it's detected by sane-something or what is the
detection tool for USB scanners called (I don't have
a scanner myself and I'm not sitting at that box).

scanimage -L also reports the device and driver correctly
and I was able to scan some images through scanimage both
grayscale and in color. The quality of the resulting image
is perfect, max. resolution is also ok.

On the other hand, it does some strange things:
	-- it's heating the lamp for a long time (like 10 seconds or so)
	before scanning.
	-- when scanning is over, the lamp doesn't return smoothly, but
	moves like 1/3 of the distance, than stops for some time and makes some
	strange sound, than moves another 1/3 and another one (2 or 3
	stops total). it doesn't hurt anything, but it's annoying to
	wait all the time.

is there some simple workaround?

Under these circumstances, until the above problems are solved,
I think you can put Packard Bell Diamond 2450 as supported in the
list in alpha state or what's your scale. I'm happy to help you if
I can, but only as a user. I speak C :), but currently I don't have
time to work on this unfortunatelly

Now I thing this is more of a user configuration problem (mine),
but I wasn't able to set her some nice X scanning application.
I tried xsane, but after I agree to the license, it displays
some "searching for available devices" and then immediatelly
"no device found". I have no chance to specify the device
manually or something, I just have to click OK. To scanimage,
I can pass the -d option, but what can I do about xsane if
it doesn't find the device immediatelly? Is there a configuration
file where I can specify something like gt68xx:/dev/usb/scanner0?

I then installed xscanimage to gimp successfully, but again,
when I want to "acquire image" it just prints that "no device
available" or "no device found" or something like this. The
manpage gives advice to specify it manually, but how do I do it
when executing xscanimage under gimp?

Do these two apps require "saned" running? I couldn't execute
it for some reason, something like that the port can't be open
or so, but I don't remember well. If you tell me saned is important,
I'll go and look at the particular error message.

It was on a RedHat 9 box with Sane 1.0.10 and the most recent
stable tarball of xscanimage I could found on author's pages
with Gimp 1.2.

I'm sorry some of the information is such fuzzy. If you consider
some of the details important, I'll go and look at the computer.

So I hope the info about the status of Diamond 2450 helps you
a little bit & many thanks for Sane and for your advices on my
problems with the GUI,

Free Software for Blind and Visually Impaired