[sane-devel] Packard Bell 2450 works with gt68xx (and problems)

Henning Meier-Geinitz henning@meier-geinitz.de
Tue, 13 Jan 2004 21:05:49 +0100


On Tue, Jan 13, 2004 at 08:44:22PM +0100, Hynek Hanke wrote:
> the Packard Bell Diamond 2450, which you didn't have
> any information about if I understand correctly,

Actually it's not even in our lists.

> seems to work with the gt68xx driver! My girlfriend received it as a
> pressent so I had no other choice than to try ;)


> I copied the firmvare .usb file from the CD with MS Windows
> drivers into the right location, as described in the manpage
> to gt68xx. It's normally available on the CD, it's not compressed
> in an .exe or something.

Ok. Please tell me the name of that file. Also please send me an
output of "sane-find-scanner -q" and "scanimage -L". 

Your scanner is probably detected because Packard Bell just put their
label on a different already supported scanner.

> Now it's detected by sane-something or what is the
> detection tool for USB scanners called (I don't have
> a scanner myself and I'm not sitting at that box).


> scanimage -L also reports the device and driver correctly

I guess it doesn't say "Packard Bell 2450", however :-)

> and I was able to scan some images through scanimage both
> grayscale and in color. The quality of the resulting image
> is perfect, max. resolution is also ok.


> On the other hand, it does some strange things:
> 	-- it's heating the lamp for a long time (like 10 seconds or so)
> 	before scanning.

That's normal. Actually, it should heat upto 30 seconds at least for
the first scan. If you use a tool like xsane instead of scanimage,
heating should only happen before the first scan.

> 	-- when scanning is over, the lamp doesn't return smoothly, but
> 	moves like 1/3 of the distance, than stops for some time and makes some
> 	strange sound, than moves another 1/3 and another one (2 or 3
> 	stops total). it doesn't hurt anything, but it's annoying to
> 	wait all the time.

I haven't headr abou this yet. I think returning the scanhead is done
by the firmware, not the backend but I haven't actually looked at the
code. No idea how to change that.

> Under these circumstances, until the above problems are solved,
> I think you can put Packard Bell Diamond 2450 as supported in the
> list in alpha state or what's your scale. I'm happy to help you if
> I can, but only as a user. I speak C :), but currently I don't have
> time to work on this unfortunatelly

Thanks for your report. I'll add this scanner to the lists.

> Now I thing this is more of a user configuration problem (mine),
> but I wasn't able to set her some nice X scanning application.
> I tried xsane, but after I agree to the license, it displays
> some "searching for available devices" and then immediatelly
> "no device found". I have no chance to specify the device
> manually or something, I just have to click OK. To scanimage,
> I can pass the -d option, but what can I do about xsane if
> it doesn't find the device immediatelly? Is there a configuration
> file where I can specify something like gt68xx:/dev/usb/scanner0?

Do you need the "-d" for scanimage? You shouldn't need it. If you need
it, "gt68xx" is usually not listed in dll.conf.

If you don't need it for scanimage but xsane doesn't find your scanner
it may be a permission problem (if you run scanimage as root but not
xsane). See "man sane-usb" for some details.

If that's also not the case you may have installed two different
versions of SANE, e.g. the one from your distribution and one that you
compiled yourself. xsane uses the old one... 

You can specify the device manually, e.g. "xsane
gt68xx:/dev/usb/scanner". But that shouldn't be necessary.

> I then installed xscanimage to gimp successfully, but again,
> when I want to "acquire image" it just prints that "no device
> available" or "no device found" or something like this. The
> manpage gives advice to specify it manually, but how do I do it
> when executing xscanimage under gimp?

I think that's not possible.

> Do these two apps require "saned" running?


> It was on a RedHat 9 box with Sane 1.0.10 and the most recent
> stable tarball of xscanimage I could found on author's pages
> with Gimp 1.2.

1.0.11 is the latest sane-frontends version but 1.0.10 should be also

Thanks for your detailed report!