[sane-devel] I can't get my scanner to work.

Henning Meier-Geinitz henning@meier-geinitz.de
Mon, 14 Jun 2004 11:36:50 +0200


On Fri, Jun 11, 2004 at 01:52:33AM -0700, Philip V. Neves wrote:
> I am trying to get my scanner to work with sane. I have a Canon LIDE20 
> usb scanner. sane-find-scanner sees the scanner but when I run scanimage 
> -L nothing comes up. Its as if the scanner isn't there.
> 77
> Here is what I get when I run sane-find-scanner. If someone could please 
> point me in the right direction I would greately appreciateit.

Which operating system and version are you using? Which SANE version?


> <device descriptor of 0x04a9/0x220d at 001:002 (Canon CanoScan)>

> <trying to find out which USB chip is used>
>    checking for GT-6801 ...
>    this is not a GT-6801 (bDeviceSubClass = 0x0)
>    checking for GT-6816 ...
>    this is not a GT-6816 (bDeviceClass = 255, bInterfaceClass = 255)
>    checking for MA-1017 ...
>    this is not a MA-1017 (bDeviceClass = 255, bInterfaceClass = 255)
>    checking for MA-1015 ...
>    this is not a MA-1015 (bcdUSB = 0x110)
>    checking for MA-1509 ...
>    this is not a MA-1509 (bDeviceSubClass = 0x0)
>    checking for LM983[1,2,3] ...
>    Couldn't claim interface: could not claim interface 0: Device or 
> resource busy
> <This USB chip looks like a LM983x?>

Something else is caliming the scanner. So either another program has
already opened the scanner or there is a kernel bug. Or you are using
Linux 2.4 and the kernel scanner driver has claimed the scanner.

SANE_DEBUG_PLUSTEK=255 scanimage -L

will print why scanimage doesn't detect the scanner. But I guess it's
the same problem: device busy.