[sane-devel] Microtek ScanMaker E6 and MacOS X doesnt work

Matto Marjanovic maddog@mir.com
Tue, 2 Mar 2004 11:42:53 -0500

 >i have tried the scan now with option norealcal uncommented which avoids the
 >hang, but then i get the Out of Memory Error.
 >Its still the same after setting MAX_DATA to 256k.
 >Looks very much like the Problem with the Microtek ScanMaker II and Mac OS

Could this be one of those "probing all LUN's" problems?
I don't really know how this all works --- but I believe the SCSI spec
 allows for each physical device (addressed by SCSI ID number) to have
 multiple internal devices (addressed by Logical Unit Number).  Some
 peripherals which don't actually have multiple LUN's report that they
 do when pressed for the information.
Conceivably, if this were happening, the OS would think that there were
 8 or so identical scanners, even though only the (first) one with LUN #0
 would actually respond to commands.

I think this would have to be fixed at the level of the SCSI configuration
 in the OS (not something fixable through SANE directly).

Anyone else have more information along this line?  I've never dealt with
 such a problem myself.

-matt m.