[sane-devel] Microtek ScanMaker E6 and MacOS X doesnt work

m. allan noah anoah@pfeiffer.edu
Tue, 2 Mar 2004 11:57:39 -0500 (EST)

this can usually be disabled in the adapter's config screen, sometimes for 
all devices, sometimes for the one problem device.

look for scsi adapter bios setup commands when booting.


On Tue, 2 Mar 2004, Matto Marjanovic wrote:

>  >i have tried the scan now with option norealcal uncommented which avoids the
>  >hang, but then i get the Out of Memory Error.
>  >Its still the same after setting MAX_DATA to 256k.
>  >
>  >Looks very much like the Problem with the Microtek ScanMaker II and Mac OS
>  >10.3.2
> Could this be one of those "probing all LUN's" problems?
> I don't really know how this all works --- but I believe the SCSI spec
>  allows for each physical device (addressed by SCSI ID number) to have
>  multiple internal devices (addressed by Logical Unit Number).  Some
>  peripherals which don't actually have multiple LUN's report that they
>  do when pressed for the information.
> Conceivably, if this were happening, the OS would think that there were
>  8 or so identical scanners, even though only the (first) one with LUN #0
>  would actually respond to commands.
> I think this would have to be fixed at the level of the SCSI configuration
>  in the OS (not something fixable through SANE directly).
> Anyone else have more information along this line?  I've never dealt with
>  such a problem myself.
> -matt m.

"so don't tell us it can't be done, putting down what you don't know.
money isn't our god, integrity will free our souls" - Max Cavalera