[sane-devel] Epson CX3100 printer scanner copier problems? scanner cannot be detected!

Karl Heinz Kremer khk@khk.net
Sun, 9 May 2004 18:19:45 -0400

Which version of Sane are you running? You may need to upgrade Sane so 
that libusb
support is working (the fact that the "usb 0x4b8 0x802" in the config 
file is
not working implies that your version of Sane does not support libusb 
The problem with these multi functional devices is that the same USB 
product ID
is used by the printer, the scanner and potentially a card reader. I 
know that
this works correctly with libusb, but I've never tried it with the 
scanner driver.
Please read the information on my web page 
for installation instructions.

Karl Heinz

On May 9, 2004, at 3:18 PM, Benjamin Khoo wrote:

> hi
> i have been trying to configure my newly acquired Epson Stylus
> printer/scanner/copier cx3100 to work in linux.
> i managed to get the printer working, but i just can't seem to get the
> scanner detected under SANE.
> when i plug in the device (which is USB), i get the following
> May 10 02:55:39 kernel: scanner.c: USB scanner device (0x04b8/0x0802)
> now attached to scanner0
> May 10 02:55:39 kernel: scanner.c: 0.4.12:USB Scanner Driver
> i have checked and double checked and each time, the device seems to be
> attached to /dev/usb/scanner0 which seem correct.
> however, when i start XSANE, it refuses to find any scanner giving the
> error below instead.
> [epson] The device at /dev/usb/scanner0 is not a supported EPSON 
> scanner
> (product id=0x802)
> i have looked at the epson backend and the product ID 0x802 seems to be
> inside the list.
> i have googled and found that this PSC is supposedly a compatible
> scanner with the 1200U. various websites has also suggested using the
> epson 1200U. however, i have no idea how to do this ( i thought it
> should be automatically detected.)
> my dll.conf file contains only the entires
> epson
> net
> and the epson.conf file for /etc/sane.d contains only
> usb /dev/usb/scanner0
> i have tried
> usb 0x4b8 0x802
> but it doesn't work as well
> i am using Redhat 9 with the kernel  2.4.20-20.9.XFS1.3.1
> i have looked at the scanner.c and found that the "single interface"
> codes has already been removed.
> from what i was told, the cx3100 is equivalent to the cx3200 the
> difference only being the fact that they are sold in different 
> countries
> (thus different model numbers).
> any advise would really be helpful.
> thanks very much
> -- 
> --
> http://www.copperblue.per.sg
> -- 
> sane-devel mailing list: sane-devel@lists.alioth.debian.org
> http://lists.alioth.debian.org/mailman/listinfo/sane-devel
> Unsubscribe: Send mail with subject "unsubscribe your_password"
>              to sane-devel-request@lists.alioth.debian.org