[sane-devel] scanner that worked with linux 2.4 does not work with 2.6 : libusb fiasco (maybe firmware upload problem)

Marcell Gal cell@x-dsl.hu
Sun, 7 Nov 2004 03:51:40 +0100

Hi Guys,

 I got a little problem using libusb.
My  Benq scanner (that is listed as supported on
http://snapscan.sourceforge.net/ )
Bus 001 Device 022: ID 04a5:20b0 Acer Peripherals Inc. (BenQ Corp.?) S2W

scanner worked fine with linux 2.4, using

modprobe scanner vendor=0x04a5 product=0x20b0
and .... /etc/sane.d# cat snapscan.conf
firmware /usr/local/scanner/benq4300u/u176v042.bin

I know that I need libusb with linux 2.6 but how do I point to the device ?
sane-find-scanner finds none

sane-find-scanner /proc/bus/usb/001/022
found USB scanner (UNKNOWN vendor and product) at device

I played a lot with snapscan.conf, so far best results with:

firmware /usr/local/scanner/benq4300u/u176v042.bin
usb 0x04a5 0x20b0
/etc/sane.d# scanimage -L
[sanei_debug] Setting debug level of snapscan to 128.
[snapscan] sane_snapscan_init
[snapscan] sane_snapscan_init: Snapscan backend version 1.4.17
[snapscan] add_usb_device(/proc/bus/usb/001/022)
[snapscan] add_usb_device: Detected (kind of) an USB device
[snapscan] snapscani_usb_open(/proc/bus/usb/001/022)
[snapscan] snapscani_check_device()
[snapscan] mini_inquiry
[snapscan] snapscan_cmd
[snapscan] snapscani_usb_cmd(0,0xbfffe160,6,0xbfffe13c,0xbfffe138 (36))
[snapscan] atomic_usb_cmd(0,0xbfffe160,6,0xbfffe13c,0xbfffe138 (36))
[snapscan] usb_cmd(0,0xbfffe160,6,0xbfffe13c,0xbfffe138 (36))
[snapscan] usb_cmd: cmdlen=6, datalen=0
[snapscan] usb_write: writing:  0x12 0x00 0x00 0x00 0x24 0x00
[snapscan] usb_write Only 0 bytes written
[snapscan] mini_inquiry: snapscan_cmd command failed: Error during device
[snapscan] snapscani_check_device: mini_inquiry failed with Error during
device I/O.
[snapscan] snapscani_usb_close(0)
[snapscan] add_usb_device(libusb:001:022)
[snapscan] add_usb_device: Detected (kind of) an USB device
[snapscan] snapscani_usb_open(libusb:001:022)
[snapscan] add_usb_device: error opening device libusb:001:022: Operation
not supported
[snapscan] sane_snapscan_get_devices (0xbffff314, 0)

No scanners were identified. If you were expecting something different,

Anyone has some suggestions what to try?