[sane-devel] scanner that worked with linux 2.4 does not work with 2.6 : libusb fiasco (maybe firmware upload problem)

Marcell Gal cell@x-dsl.hu
Sun, 7 Nov 2004 12:52:13 +0100


> You don't need to, it'll be found automatically.

yes, if I were lucky. But I'm not.
So let's say it "should" be found automatically.

> > sane-find-scanner finds none
> Try running sane-find-scanner without any arguments. If no scanner is
> found it's most likely a permission problem.

This was the first I tried. It finds none.
I have the permissions set up.
Also, just to avoid permission problems,
I'm trying to run as root before I move
to a less powerful (dangerous) user.
Also, running sane-find-scanner -v
would (as far as I understand right) warn immediately
if it was just the permission.

> See "man sane-usb" for possible solutions.

I read it over many times, and tried everything.

> > I played a lot with snapscan.conf, so far best results with:
> >
> > firmware /usr/local/scanner/benq4300u/u176v042.bin
> > usb 0x04a5 0x20b0
> > /proc/bus/usb/001/022
> > libusb:001:022
> You only need two entries, the firmware entry and the "usb 0x04a5
> 0x20b0". You _must not_ use any device entries.

Those I tried first:
usb 0x04a5 0x20b0
firmware /usr/local/scanner/benq4300u/u176v042.bin

(and also in reverse order).

> The problem is that the device file will change dynamically depending
> on when and how often you switch on your scanner. There's no way to
> have the scanner use the same device file every time.

I'm aware of that, I just tried everything since nothing documented worked
with linux kernel 2.6.
I could find the device automatically using a 5-liner script, if that

Let me rephrase. Without the device hint , neither
sane-find-scanner  -v (no device argument)
scanimage -L   ( just the mentioned 2 lines in snapscan.conf, no device )
finds anything.

/etc/sane.d# scanimage -L
[sanei_debug] Setting debug level of snapscan to 128.
[snapscan] sane_snapscan_init
[snapscan] sane_snapscan_init: Snapscan backend version 1.4.17
[snapscan] sane_snapscan_get_devices (0xbffff314, 0)

No scanners were identified. If you were expecting something different,

The desription in the last mail was the best-so-far result, when
the snapscan backend actually tries to talk to the device.
I tried resetting the scanner from time to time (and changed device bus
location to match)
to avoid the scanner being confused of some messages.

I can grant r..t access to the box if it helps
(if someone asks in private mail, mentioning their /src/ host IP if


# dpkg -l 'sane*'
ii  sane                 1.0.13-1             scanner graphical frontends
ii  sane-utils           1.0.14-7             API library for scanners --