[sane-devel] saned refuses to reply

Henning Meier-Geinitz henning@meier-geinitz.de
Mon, 22 Nov 2004 19:12:16 +0100


On Mon, Nov 22, 2004 at 09:37:17AM +0900, Olaf Meeuwissen wrote:
> Hmm, haven't checked that.  Does this mean that saned was not designed
> to run in standalone mode (when _not_ debugging)?

Yes. Well, in fact you can run saned standalone with debug messages
turned off but it's still not what you usually call a stand-alone
server. It can only accept one connection and exits after the
connection is closed.

> >> Only when I run it with the -d flag do I get the output mentioned
> >> above.
> >> 
> >> Does anyone have an idea what might be wrong.
> >> # Upgrading to 1.0.15 is likely not an option ...
> >
> > There haven't been any bugs in saned that stopped it from starting or
> > detecting the scanner for years so that's not the root of the problem.
> >
> > Have you checked that saned is allowed to access your scanner? I.e. if
> > the device file (e.g. /proc/bus/usb/001/003) is writable by saned:saned?
> Like I mentioned, when running saned in debugging mode there is no
> problem at all.

Do yur run saned as user saned:saned in stand-alone mode? If you run
it as normal user or root the permissions may be ok but from inetd
it's usually run as saned:saned.