[sane-devel] saned refuses to reply

Olaf Meeuwissen olaf@epkowa.co.jp
Mon, 22 Nov 2004 09:37:17 +0900

Henning Meier-Geinitz <henning@meier-geinitz.de> writes:

> Hi,

Hi Henning, 

> On Fri, Nov 19, 2004 at 06:33:57PM +0900, Olaf Meeuwissen wrote:
>> I tried running saned in standalone mode (after stopping inetd).  It
>> immediately exists successfully (exit status 0).  That is:
>>   # saned && echo OK
>>   OK
> That can't work. You'll get an error in syslog about a failing
> getpeername command.

Hmm, haven't checked that.  Does this mean that saned was not designed
to run in standalone mode (when _not_ debugging)?

>> Only when I run it with the -d flag do I get the output mentioned
>> above.
>> Does anyone have an idea what might be wrong.
>> # Upgrading to 1.0.15 is likely not an option ...
> There haven't been any bugs in saned that stopped it from starting or
> detecting the scanner for years so that's not the root of the problem.
> Have you checked that saned is allowed to access your scanner? I.e. if
> the device file (e.g. /proc/bus/usb/001/003) is writable by saned:saned?

Like I mentioned, when running saned in debugging mode there is no
problem at all.
Olaf Meeuwissen                            EPSON KOWA Corporation, PF1
FSF Associate Member #1962           sign up at http://member.fsf.org/
GnuPG key: 6BE37D90/AB6B 0D1F 99E7 1BF5 EB97  976A 16C7 F27D 6BE3 7D90
Penguin's lib!       -- I hack, therefore I am --               LPIC-2