[sane-devel] Re: strange problems LIDE30

Brian K. White brian@aljex.com
Wed, 6 Oct 2004 17:07:46 -0400

Chris McKeever wrote:
> some more tests get me some new results.
> 1 - I have noticed that with 3 different USB 2.0 cards, that the
> scanner will not register itself as a USB 2.0 device, it only
> registers as a 1.1 (CD Wiriters register as 2.0, so I know that the
> card and the kernel are recognizing it properly)
> 2 - I moved the scanner to the built-in USB 1.1 port, and I was able
> to finish a scan at 300 DPI and 600 DPI (although it takes quite some
> time)
> 3
> 3 - 1200 DPI still hangs, and letting it sit, I get: error during
> read: error during device I/O.
> any suggestions?
> thanks
> On Wed, 6 Oct 2004 13:22:31 -0500, Chris McKeever
> <techjedi@gmail.com> wrote:
>> I have been wrestling with this for a while now, and not turning up
>> much through searching the web.  I have installed SANE
>> sane-backends-1.0.14 and have a CANON lide30 scanner.
>> At low resolutions it will process fine.  If I go to 300 is fails at
>> about 75% and anyhting higher wont even start.
>> I had it working with an LIDE20 - until that unit crapped out - the
>> optic bar would just pin itself to the edge and grind.
>> I am connecting to the SANE backend via XSANE from a remote linux box
>> as well as a remote windows box - very similar results (the
>> connection itself works, just scanning isnt working well)
>> Any suggestions?
>> thanks

LiDE 30  _IS_ only a usb 1.1 device.
There are sloppily written advertisements on various shopping sites that 
list it as usb2.0 but in truth, the lide30 is usb1.1
Later lide50 is usb2.0
go to the canon site instead of guessing or trusting others (hey, including 
me :)

I have a 30 and a 2.0 card and went through the same motions you are and 
finally I did what I should have done first and consulted the only 
authoritative source and all mysteries were solved.

I never tried to scan at 1200 though, trying now...
It's going but incredibly slowly at 2400 full color (what bit depth is "full 
The manufacturer says that it does 1200x2400 optically, but xsane only 
offers a listbox that says a single value from 0 to 2400, no XXXxYYY 
choices, so I picked 2400 just to go for a worst case scenario but I have no 
idea what it's actually going to do.
A lie, only actualy produce 1200x1200? a distorted image? silently double 
every pixel in one direction? silently double every pixel in both 
directions? or maybe the scanner will do the doubling in one direction in 
firmware and present sane with 2400x2400 data?

It's only at about 10 or 15% progress after 20 minutes so I'll send another 
post when it's done, or when it crashes.
This box has a gig of ram so hopefully it's enough for this worst-case 
scenario if sane doesn't open a file and work with smaller chunks in ram. 
This is a dual 1gig p3 too. That might be relevant by making it more likely 
that there is always a cpu available to service the usb interrups? Or 
rather, that the one cpu that seems to be the only one that even sees 
interrupts, is more likely to be able to keep up.

It's basically a straight suse personal 9.1 with yast configured to use 

Brian K. White  --  brian@aljex.com  --  http://www.aljex.com/bkw/
filePro BBx  Linux SCO  Prosper/FACTS AutoCAD  #callahans Satriani