[sane-devel] Re: strange problems LIDE30

Brian K. White brian@aljex.com
Wed, 6 Oct 2004 21:09:50 -0400

Brian K. White wrote:
>> It's only at about 10 or 15% progress after 20 minutes so I'll send
> still cranking away
> just over 50%
> Now I wish I'd used the time command so I can see just how long this
> will take even if I go out to eat and it finishes while I'm gone.
> Then we could look at the total data and total time and see if it
> transferred at full usb 1.1 speed. Seems like it should be able to go a 
> lot faster than this
> with 12 megabit available.

Just crashed, 8:07 pm
I sent my original mail at 5:07 pm
I probably started that email (and the xsane process) at about 4:30 pm

It was xsane in kde so I don't have any error message. It just winked out.
It was somewhere near 90% but I don't think it was done.
It's speed was constant the whole time and I had looked at it a few minutes 
before and it was still just under 90% and I don't think it was nearly 
enough time for it to have gone the rest of the way, maybe only another 1 or 
2 %.
So I will tentatively say it failed while in progress, not after it was done 
scanning and tried to do whatever it does next.
I was scanning "to viewer".

This box is not overclocked at all and has not exhibited any other signs of 
flaky hardware so I don't suspect ram/cpu/etc
It's running 2 seti@home processes 24/7 and I do a fair/medium amount of 
work on it, lots of rxvt & ssh to other boxes, some gimp, lots of konquerer, 
xmms is playing some 128 kbit shoutcast stream almost 24/7, I have a fairly 
large java app that runs 24/7 that interfaces with our voip phone system, I 
play the occasional dvd. None of these has yet surprised me.
I have not used the adaptec usb 2.0 pci card for very much at all although 
the optical mouse is plugged in to it and the scanner, and I have used the 
scanner and xsane without incident several times before but only at 
300dpi-gray and 200dpi-bw.

I wasn't touching the machine at the time. xmms was not playing, the mouse 
was not moving, the screensaver was up.
(I'm working on my laptop but I'm at the same desk)

At least I can go eat now and know I won't miss anything :)

I'm not above suspecting the usb card. I have not been able to get my 
unpowered usb2.0 2.5" hard drive to work on it.
Sorry, I can't define "not work" since I gave up a few months ago and by now 
I don't recall what I tried and what I saw because it was never actually 
important to me.
But that could just as easily be the enclosure or drive and not the usb 
card. The drive & enclosure works on my laptop, but it does give windows 
delayed write failed error messages once in a while if it's left plugged in 
and idle a long time. *shrug*

I could do some transfers to a 512 meg sd card in a jump drive trio and see 
if that is reliable.
sd cards are normally only about 1 megabit, but I have a 10/9 mb read/write 
card. that should be an ok test.
I'll just to simple large monolithic transfers so as to minimize the number 
of write cycles I use up.
I'll dd 500 megs directly to it a few times, and same thing to read.
I'll start with a given file, dd it on, dd it back to a new file and cmp the 
files to verify that the writes & reads didn't have a silent error that 
corrupted the data.
If that works I'll call the usb card stable at least in usb1 mode.

Brian K. White  --  brian@aljex.com  --  http://www.aljex.com/bkw/
filePro BBx  Linux SCO  Prosper/FACTS AutoCAD  #callahans Satriani