[sane-devel] snapscan: Identified scanner still doesn't work

Henning Meier-Geinitz henning@meier-geinitz.de
Sun, 17 Oct 2004 17:05:19 +0200


On Sun, Oct 17, 2004 at 04:35:13PM +0200, Tim Boneko wrote:
> I tried to build the  snapscan-backend from cvs, but couldn't: 
> "make" ended up with
> >gcc -o gamma4scanimage gamma4scanimage.o  -lm
> >gcc -c -g -O2 -W -Wall -Wcast-align -Wcast-qual -Wmissing-declarations 
> >-Wmissing-prototypes -Wpointer-arith -Wreturn-type -Wstrict-prototypes 
> >-pedantic -ansi -DHAVE_CONFIG_H -I. -I. -I../include -I../include 
> >-DPATH_SANE_CONFIG_DIR=/usr/local/etc/sane.d          
> >-DPATH_SANE_DATA_DIR=/usr/local/share           -DV_MAJOR=1 
> >-DV_MINOR=0 sane-desc.c
> >gcc -o sane-desc 
> >sane-desc.o  ../sanei/libsanei.a ../lib/liblib.a /usr/lib/libusb.so 
> >-lnsl -lm
> >make[1]: Leaving directory 
> >`/archiv/progs/snapscan-cvs/sane-backends/tools'
> >making all in doc
> >make[1]: Entering directory 
> >`/archiv/progs/snapscan-cvs/sane-backends/doc'
> >Generating sane.ps...
> >make[1]: *** [sane.ps] Fehler 1

latex or some other TeX tool didn't like the commands it got. 
configure checks if these commands are available but maybe you have a
rather strange TeX installation :-)

Anyway, just enter "make install". Make looks into the doc directory
after the backend directory so make install should still work. It may
complain about sane.ps but you can ignore it.

Ifyou like to debug the sane.ps issue, edit doc/Makefile, search for
the rule for sane.ps and delete the "@" in front of the commands and
all the ">/dev/null" and "2>/dev/null". That should print some more
reasonable error messages.

> T:  Bus=03 Lev=01 Prnt=01 Port=02 Cnt=01 Dev#=  7 Spd=480 MxCh= 0
> D:  Ver= 2.00 Cls=ff(vend.) Sub=ff Prot=ff MxPS=64 #Cfgs=  1
> P:  Vendor=04b8 ProdID=0121 Rev= 0.00
> S:  Manufacturer=EPSON
> S:  Product=EPSON Scanner
> C:* #Ifs= 1 Cfg#= 1 Atr=c0 MxPwr=100mA
> I:  If#= 0 Alt= 0 #EPs= 3 Cls=ff(vend.) Sub=ff Prot=ff Driver=(none)
> E:  Ad=81(I) Atr=02(Bulk) MxPS= 512 Ivl=0ms
> E:  Ad=02(O) Atr=02(Bulk) MxPS= 512 Ivl=0ms
> E:  Ad=83(I) Atr=03(Int.) MxPS=   8 Ivl=4096ms
> The output lacks the two "S" lines (Manuf. & Product) when i "cat" it 
> while the scanner led is flashing.

I think when you cat the devices file the kernel tries to get the
strings by sending a USB control message to the scanner. If the
scanner is confused, it will not react to these messages and they time