[sane-devel] snapscan: Identified scanner still doesn't work

Tim Boneko tim@boneko.de
Sun, 17 Oct 2004 16:35:13 +0200

Content-Type: text/plain;
Content-Transfer-Encoding: quoted-printable
Content-Disposition: inline

Hello from southern germany,

after lots of googling and searching i finally found this mailing list,=20
thank goodness. snapscan.sourceforge.net doesn't mention this.=20
I hope someone can help me here:

I bought an Epson Perfection 2480 Photo and tried to install it using=20
the instructions on the mentioned sf-site. Software as follows:=20

Debian system, kernel, sane 1.0.12 from unstable, libsane=20
1.0.14-7 from unstable - building the cvs version failed, see below.=20
libusb 0.1.5 from unstable, hotplug 20040329 ditto.
My /etc/sane.d/snapscan.conf is attached below. The firmware file to be=20
uploaded is in /etc/sane.d.=20

The scanner is detected correctly by sane-find-scanner:

>found USB scanner (vendor=3D0x04b8 [EPSON], product=3D0x0121 [EPSON       =
>Scanner]) at libusb:003:004

Any access to the scanner (xsane and the like) end up in an error=20

>Couldn't start scanner - error during device i/o=20

(translated from german)

=2E..so i tried sane-troubleshoot without any result i didn't already=20
know. The test-scan ended with the following in /var/log/syslog:

>ehci_hcd 0000:00:02.2: qh c1577780 (#17) state 1
>usb 3-3: usbfs: USBDEVFS_BULK failed ep 0x81 len 3856 >ret -75
>usb 3-3: bulk timeout on ep2out
>usb 3-3: usbfs: USBDEVFS_BULK failed ep 0x2 len 6 ret -110

To me this looks like a usb problem, right? After a failed access to the =20
scanner the led of it keeps flashing for minutes. During this time a=20
"cat /proc/bus/usb/devices" hangs for 30 seconds before giving out what=20
i've attached below.

I tried to build the  snapscan-backend from cvs, but couldn't:=20
"make" ended up with

>gcc -o gamma4scanimage gamma4scanimage.o  -lm
>gcc -c -g -O2 -W -Wall -Wcast-align -Wcast-qual -Wmissing-declarations=20
>-Wmissing-prototypes -Wpointer-arith -Wreturn-type -Wstrict-prototypes=20
>-pedantic -ansi -DHAVE_CONFIG_H -I. -I. -I../include -I../include=20
>-DPATH_SANE_CONFIG_DIR=3D/usr/local/etc/sane.d         =20
>-DPATH_SANE_DATA_DIR=3D/usr/local/share           -DV_MAJOR=3D1=20
>-DV_MINOR=3D0 sane-desc.c
>gcc -o sane-desc=20
>sane-desc.o  ../sanei/libsanei.a ../lib/liblib.a /usr/lib/libusb.so=20
>-lnsl -lm
>make[1]: Leaving directory=20
>making all in doc
>make[1]: Entering directory=20
>Generating sane.ps...
>make[1]: *** [sane.ps] Fehler 1
>make[1]: Leaving directory=20
>make: *** [all-recursive] Fehler 1

That's what i've achieved so far. Any hints are greatly appreciated.


To complete the overkill, here's some output of /proc/bus/usb/devices=20
after booting:

T:  Bus=3D03 Lev=3D01 Prnt=3D01 Port=3D02 Cnt=3D01 Dev#=3D  7 Spd=3D480 MxC=
h=3D 0
D:  Ver=3D 2.00 Cls=3Dff(vend.) Sub=3Dff Prot=3Dff MxPS=3D64 #Cfgs=3D  1
P:  Vendor=3D04b8 ProdID=3D0121 Rev=3D 0.00
S:  Manufacturer=3DEPSON
S:  Product=3DEPSON Scanner
C:* #Ifs=3D 1 Cfg#=3D 1 Atr=3Dc0 MxPwr=3D100mA
I:  If#=3D 0 Alt=3D 0 #EPs=3D 3 Cls=3Dff(vend.) Sub=3Dff Prot=3Dff Driver=
E:  Ad=3D81(I) Atr=3D02(Bulk) MxPS=3D 512 Ivl=3D0ms
E:  Ad=3D02(O) Atr=3D02(Bulk) MxPS=3D 512 Ivl=3D0ms
E:  Ad=3D83(I) Atr=3D03(Int.) MxPS=3D   8 Ivl=3D4096ms

The output lacks the two "S" lines (Manuf. & Product) when i "cat" it=20
while the scanner led is flashing.

Here's my snapscan.conf:

firmware /etc/sane.d/esfw41.bin
usb 0x04b8 0x0121

Adding a line "/dev/usb/scanner0 bus=3Dusb" doesn't change anything. Same=20
for an empty firmware file.

Content-Type: application/pgp-signature

Version: GnuPG v1.2.5 (GNU/Linux)