[sane-devel] USBDEVFS_BULK failed errors - Epson Perfection 2400 Photo

David Cook David Cook <davidtcook@gmail.com>
Thu, 9 Sep 2004 02:40:22 +0100

On Wed, 8 Sep 2004 19:30:12 -0400, Karl Heinz Kremer <khk@khk.net> wrote:
> David,
> I don't think that this is a Sane problem, the message you get is
> from the USB system.
> If you have more USB ports on your system, try a different port, if
> you have the scanner connected via a hub, try to connect the
> scanner directly. Try a different USB cable. If you have access to
> a USB PCI card, put that into your computer and give it another
> try.

       Until now, I had tried both of the front-of-case USB ports on
my PC, and neither worked with the scanner.  Tonight, I tried one of
the rear ports, and the scanner seems to work fine there (first I
tried a preview and scan in flatbed mode, then I made two scans of
negatives using the transparency adapter - no problems, no timeouts).

Obviously, this is one of those things which isn't supposed to make a
difference, but apparently it does.

I don't know if this "solution" will help the others affected by this
problem, though - maybe we need to visit the USB development list and
see if they can help ?