[sane-devel] Problems with Epson Perfection 1670

Oliver Schwartz Oliver.Schwartz@gmx.de
Tue, 14 Sep 2004 22:07:06 +0200


> I have problems with my Epson Perfection 1670 using usb. The same
> problems appear for the latest cvs version of sane, and also with
> knoppix 3.4 using 2.6 kernel. If I use the `vuescan' software it
> works perfectly. I run fedora core 1 with the 2.4.22-1.2199 kernel.
> When I do scanning or aquire a preview, it starts to scan but then
> it just stop. The cpu goes up to 100% and it just goes on forever.
> I have been able to do scan a handful of times, but suddenly it
> just stop.

I haven't seen this behaviour before.

> enable SANE_DEBUG_XSANE, gives me infty output after the stop, as
> [snapscan] sane_snapscan_read (0x859c230, 0xbff16b00, 8192,
> 0xbff16afc) [snapscan] RGBRouter_get: remaining=8192,
> pself->remaining=2172852, round_req=14868, cb_size=14868
> [snapscan] (undef): EOF
> Anyone having a clue of what's going on?

It seems the scanner just stops sending data. Can you send me the 
complete log, please? 

Have you tried if disconnecting any other USB devices changes 
anything? Are there any other error messages in 
the /var/log/messages?