[sane-devel] HP PSC 1315.

Scott gnea@garson.org
Sun, 19 Sep 2004 05:00:16 -0400

Hello, I'm new to this list but have searched through it quite a bit to
find the information I've been looking for, as well as google.com and
yahoo.com.  Alas, those facets have failed and now I am here.  So I'll
give it to you straight and hopefully this issue can be solved:

I have an HP PSC 1315 (1310 class) USB 2.0/1.1 all-in-one
printer/scanner/copier.  It is connected to a USB 2.0 port on an Asus
A7N8X-E motherboard running an athlon xp 1700 cpu with 512 megs of DDR
ram.  The system itself runs Debian GNU/Linux [sid] with a compiled
kernel 2.6.7 along with CUPS to handle the printing bit of things.
Printing itself is phenominal, this is a SWEET printer.  

However, scanning doesn't want to work.  I have installed sane
(frontends is at version 1.0.12 currently in the distribution) along
with hpoj (current distribution places it at version 0.91, which AFAIK
should work).

libusb is version 0.1.8

Here is some relevent information (please feel free to grind me for more
information regarding anything - I'm a bit tired right now but I want to
fix this because we have another one and need to get it setup and
working in linux as well - IOW, we have 2 identical 1315's to play
around with):

celery:~# sane-find-scanner 

  # No SCSI scanners found. If you expected something different, make
  # sure that
  # you have loaded a SCSI driver for your SCSI adapter.
found USB scanner (vendor=0x03f0 [hp], product=0x3f11 [psc 1310 series ]) 
at libusb:003:009

celery:~# lsusb | grep Hewlett
Bus 003 Device 009: ID 03f0:3f11 Hewlett-Packard 

in /etc/usbmgr/usbmgr.conf I have added the following line:
# PSC 1315 [HP]
vendor 0x03f0 product 0x3f11 module usblp


I have done some digging around and have discovered that as of 2.6.3
(correct me if I'm wrong) the scanner.o module is no longer used and
instead libusb is what's there.  When I start hpoj I get the following
syslog entries:

ep 19 04:42:41 celery ptal-printd: ptal-printd(mlc:usb:psc_1315)
successfully initialized using /var/run/ptal-printd/mlc_usb_psc_1315*. 
Sep 19 04:43:10 celery ptal-mlcd: SYSLOG at
dev=<mlc:usb:psc_1315@/dev/usb/lp0>, pid=1871, e=11, t=1095583390
ptal-mlcd successfully activated, mode=1284.4. 

Running the command:
celery:~# xscanimage hpoj:mlc:usb:psc_1315

results with: Failed to open device `hpoj:mlc:usb:psc_1315': Error
during device I/O.

So I delve a little further....

celery:~# lsof | grep 1315
ptal-prin  1874   root    4r     FIFO       3,69             293251
ptal-prin  1874   root    5r     FIFO       3,69             293252
ptal-prin  1874   root    6r     FIFO       3,69             293253
ptal-prin  1874   root    7r     FIFO       3,69             293254
ptal-prin  1874   root    8r     FIFO       3,69             293255
ptal-prin  1874   root    9r     FIFO       3,69             293256
ptal-prin  1874   root   10r     FIFO       3,69             293257
ptal-prin  1874   root   11r     FIFO       3,69             293258
ptal-prin  1874   root   12r     FIFO       3,69             293259
ptal-prin  1874   root   13r     FIFO       3,69             293260

Some more pertinent info:

celery:~# ptal-device 

(in the following I separated each field to make reading it easier)

celery:~# ptal-devid mlc:usb:psc_1315
MDL:psc 1310 series;


celery:~# ptal-hp mlc:usb:psc_1315 device
Model name:        psc 1310 series
Model number:      Q5765A
Serial number:     CN45VB61D0O2
Firmware version:  R0012xxNx
Firmware datecode: (unavailable)


celery:~# ptal-hp mlc:usb:psc_1315 display
[nothing appears, just a few blanks lines]


celery:~# ptal-hp mlc:usb:psc_1315 clock  
Device clock: Jan-1-2000 12:00:00 AM

I tried resetting the clock to a, pardon the pun, saner value but it
refuses to budge, leading me to believe that the internal clock is not
really used....


celery:~# scanimage -d hp:/dev/usb/scanner0
scanimage: open of device hp:/dev/usb/scanner0 failed: Invalid argument
celery:~# scanimage -d hp:/dev/usb/scanner1
scanimage: hp-option.c:3710: hp_optset_fix_geometry_options: Assertion
`tl_x && tl_y && br_x && br_y' failed.


I really can't think of much more... hpoj is listed at the bottom of

I am thinking that perhaps I will have to checkout the latest CVS
version of hpoj, but that will have to wait as I have a very busy
weekend to complete.  I did find the thread regarding the PSC 1210 so
that's what leads me to think that that's the solution I should try..
but figuring that 0.91 is the current release, and at the time of THAT
posting the CVS was at 0.9... perhaps there's something I'm just not
doing or perhaps the scanner has some extra protocol stuff that's not
known about yet... TIA!!

         .oO Gnea [gnea at garson dot org] Oo.
            .oO url [http://gnea.net] Oo.

"You can tune a filesystem, but you can't tune a fish." -Kirk McKusick