[sane-devel] /proc/bus/usb/001/002 , write permission changes required, is that normal behaviour?

Rayudu Addagarla rayuduak at gmail.com
Tue Aug 30 20:01:52 UTC 2005

When i run scanimage -L as user i dont see the devices.
when i run as root i can see the devices.
i set Debug on and i see plustek backend says open failed.

sane-find-scanner gives that device is libusb:001:002
The permission on the /proc/bus/usb/001/002 device file has read permissions 
to everyone.
-rw-r--r-- 1 root root 43 2005-08-29 17:42 002

I had to change to have write permissions to other like,
-r--r--rw- 1 root root 57 2005-08-30 12:22 002
then only as user i can see the device with scanimage -L

Is this a common behavior? I expect to have only read perms and does not 
require write perms.

My system configuration:
SuSE , Version = 9.1

Kondala Rayudu Addagarla
Java Developer & Unix/Linux Administrator.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.alioth.debian.org/pipermail/sane-devel/attachments/20050830/1ef1d6fe/attachment.html

More information about the sane-devel mailing list