[sane-devel] /proc/bus/usb/001/002 , write permission changes required, is that normal behaviour?

m. allan noah anoah at pfeiffer.edu
Tue Aug 30 20:16:22 UTC 2005

how are you going to send commands to the scanner, if you cant write to 

look at hotplug, it can be configured to set the permissions however you 
want. oh and you might want to let root and group still write to it...


On Tue, 30 Aug 2005, Rayudu Addagarla wrote:

> Hello
> When i run scanimage -L as user i dont see the devices.
> when i run as root i can see the devices.
> i set Debug on and i see plustek backend says open failed.
> sane-find-scanner gives that device is libusb:001:002
> The permission on the /proc/bus/usb/001/002 device file has read permissions
> to everyone.
> -rw-r--r-- 1 root root 43 2005-08-29 17:42 002
> I had to change to have write permissions to other like,
> -r--r--rw- 1 root root 57 2005-08-30 12:22 002
> then only as user i can see the device with scanimage -L
> Is this a common behavior? I expect to have only read perms and does not
> require write perms.
> My system configuration:
> SuSE , Version = 9.1
> sane-frontends-1.0.13-2
> xsane-gimp-0.95-3
> sane-backends-1.0.15-9
> xsane-0.95-3
> thanks

"so don't tell us it can't be done, putting down what you don't know.
money isn't our god, integrity will free our souls" - Max Cavalera

More information about the sane-devel mailing list