[sane-devel] HP ScanJet 2300C and genesys backend

Nightwulf nightwulf@night-wulf.de
Sun, 12 Jun 2005 22:44:07 +0200


first I want to say big thanks to all the guys involved in the genesys 
backend. I was nearly ready to sell the scanner and buy another one. Normally 
I have a close look at what hardware I buy in oder to get linux compatible 
hardware. This time I thought "well, it's a HP, it will 
work".....uhm...yeah :)
Now it's time to give you guys at least a complete feedback of what I did and 
how it worked:
Yesterday I tried the driver with archlinux, custom kernel and 
libusb-0.1.10a, sane snapshots from 05/06/11. After some smaller difficulties 
in figuring out how the device line has to be set for libusb (no problems 
with integrating the experimental genesys cvs code to the sane-snapshots 
whatsoever btw...great README),  I was able to scan a whole page with 
scanimage. The only strange thing was, that sane-find-scanner did find the 
scanner while scanimage -L didn't. After a reboot (perhaps usb-config-stuff?) 
it worked with scanimage -L and xscanimage as well as kooka also as a normal 
user. I was impressed :)
I did some tests then and found some problems with the different applications 
I wanna let you know of:
1. xscanimage:
- 600dpi res, color, 16bits -> pic seems to be distorted (looks like a picture 
for the old 3d-glasses, red and green for left and right eye)
- acquire preview doesn't work, the scan light carrier seems to hit the front 
of the scanner case (switched off quickly then)

2. kooka
- 600 dpi, color mode seems to hang up the scanner...the scan light seems to 
do one step forward and one back all the time
- preview doesn't work, scanning lights are switched on and then nothing 
happens anymore

3. scanimage
- no problems so far using only standard scans (whole page, gray or color 

I hope this helps. Please don't hesitate to tell me if I can be of further