[sane-devel] SuSE 9.3, HP PSC 1510 is not a scanner

Franz Brandner franz.brandner at web.de
Thu Nov 3 01:35:04 UTC 2005

First of all (and I mean it) thank you for your quick and kind answers to my 
questions. Yet, despite all advice and quite some effort, I still haven't 
managed to solve my problem, PSC 1510 is a perfect printer but it won't scan, 
although it seems to be properly installed (as far as i can tell). Well, to 
make a long story short I'm running out of energy now. But to give it one 
last try and for your information as well here's what I did and tried, 
including the poor results:

as already mentioned "sane-find-scanner" put out: USB scanner, vendor HP, PSC 
1500 series, at libusb:001:004

"/sbin/lsusb": Bus 001 Device 004: ID... Hewlett-Packard; Bus 001 Device 001: 
- no ID -  (which seems to be normal I understood)

yet, scanning cannot be installed with YaST -> Hardware -> Scanner, the device 
is listed as above (USB scanner, vendor HP, PSC 1500 etc.), as there is no 
entry for it in the next step I selected "HP - most multifunction... 
hpaio" (as recommended), the result is: driver active, no active scanner

"rchplip status" verified that hplip is up and running

"dmesg | grep -i usb" put out no error or failure, I only noticed that no 
'scanning device' was mentioned there, just a 'printing device'

"egrep -i 'hplip|hpiod|hpssd'/var/log/messages | tail -n40" brought out 
nothing, but maybe I did something wrong there? Tried it several times, kept 
waiting for up to 40 minutes, nothing happened. Looked up "/var/log/messages" 
directly then, the only error I could find was 'linux hp: unable to 
open /var/run/hpiod.port: no such file or directory'. I suppose this has 
nothing to do with my problem itself, just wanted to mention it to make sure.

I also tried the hpoj driver, same result: driver active, no active scanner. 
Although I always uninstalled hplip before installing hpoj, the last time i 
tried the hpoj I got a failure notice after "/usr/sbin/ptal-init setup", I 
couldn't really understand that. Not so important as hplip would be first 
choice anyway as far as I hopefully correctly learned.

One last question, I am considering an upgrade anyway: Would things probably 
work any better with SuSE 10.0?

Thanks for listening.

----------  Weitergeleitete Nachricht  ----------

Subject: SuSE 9.3, HP PSC 1510 won't scan?
Date: Samstag, 29. Oktober 2005 15:26
From: Franz Brandner <franz.brandner at web.de>
To: sane-devel at lists.alioth.debian.org

Priniting works perfectly with HP's PSC 1510 using HPLIP and HPLIP-HPIJS
 after I got the appropriate PPD, but it won't scan. Trying to install the
 device as a scanner with YaST it is listed as "USB scanner, vendor HP, PSC
 1500 series", as there is no entry for it then in the list of known devices
 I selected "HP - Most Multifunction devices, driver HPAIO" (as recommended),
 result: the driver is running, but there is no active scanner. With HPOJ 
 and the driver for the PSC 1300 series (similar model, HP said) the result
 was the same. The command "sane-find-scanner" also tells me that it should
 work, "scanimage -L" finds nothing. I ran all these commands as ordinary user
 and root as well. "/sbin/lsusb" lists it as "Bus 001 Device 004: ID ...   ; 
  Bus 001 Device 001: no ID" by the way. Maybe someone knows what I could do
 to get this model to scan? I hope, I do not have to manually create it as
 mentioned on www.xs4all.nl, or would that be a possible way at all? As I am
 not yet very familiar with Linux, especially not with consoles and
 terminals, I would be thankful for any help that is as easy to follow and
 understand as possible. Any little piece of advice could probably help me.


More information about the sane-devel mailing list