[SOLVED] Re: [sane-devel] Canon LiDE 30 FC 5 hotplug question

Richard England rengland at europa.com
Sun Apr 30 17:11:47 UTC 2006

Martin Collins wrote:
> On Sat, 29 Apr 2006 23:29:52 -0700
> Richard England <rengland at europa.com> wrote:
>> I tried limiting this by adding  GROUP="scanner" to the UDEV rule, 
>> creating the group "scanner" and adding my account to that group
>> but it seems that unless I do a "newgrp scanner" to change my
>> primary group, I can't access it.
> If you start a new shell (or log out and in again) it will include
> scanner in its groups.
> You could set the perms to 0660.
>> I'd be glad to learn the proper way to limit this further, or the 
>> Gnu-Linux-proper way to use groups (they don't seem to be exactly
>> as I'm used to on Unix)  if anyone wants to enlighten me.
> There's no difference AFAIK...
>> The only lingering question in my mind is,  "is this as it should
>> be?". Shouldn't there be something in place to allow the general
>> user to simply plug in a supported scanner and use it without be
>> root or modifying the UDEV rules?
> IIRC the Debian package sets up a scanner group, and UDEV I think,
> maybe you should raise it with the FC package maintainer (one would
> hope they hang out here anyway).
> Martin
You were right.  I tried a new shell but I hadn't tried logging back 
in.  When I logged out and back in, the new group was recognized and the 
scanner was available.

That means the entry in:



SYSFS{idVendor}=="04a9", SYSFS{idProduct}=="220e", 
SYMLINK+="scanner-%k",  GROUP="scanner", MODE="0660"

Thanks for your response.

/Linux, and Open Software, an alternative./
Registered Unix <http://counter.li.org> user #409453

More information about the sane-devel mailing list