[sane-devel] Plustek scanner - follow up

Immanuel CRC Office office at immanuelministries.ca
Fri Aug 4 15:48:27 UTC 2006

Immanuel CRC Office wrote:
> Gerhard Jaeger wrote:
>> On Thursday 03 August 2006 16:51, Immanuel CRC Office wrote:
>>> Okay, so I'm getting somewhere.
>>> Plustek OpticPro 9639P+, parallel port
>>> using plustek_pp backend.
>>> I have to run all as root so far.
>>> scanimage -L gives:
>>> device `plustek_pp:parport0' is a Plustek 9636P+/Turbo parallel port 
>>> flatbed scanner
>>> device `hpaio:/par/HP_LaserJet_1200?device=/dev/parport0' is a hp 
>>> HP_LaserJet_1200 multi-function peripheral
>>> (Great! I have two connected in series to my parallel port. Printer 
>>> still works. Ideally, I want both connected and both working, so 
>>> we're getting somewhere.)
>>> When I do:
>>> scanimage -d plustek_pp:parport0 -p > image.pnm
>>> I heard a bit of sounds from the scanner. Then I got:
>>> scanimage: sane_read: Error during device I/O
>>> 1. Still can only do stuff as root.
>>> 2. Need to fix error.
>>> Ideas?
>> Hi,
>> I didn't follow the thread so far, so some hints might be doubled:
>> - remove the printer from the chain as this might cause problems
>>   (has also be stated by Plustek)
>> - make sure to have any ECP mode disabled in BIOS (set the port to
>>   SPP, BiDi or EPP)
>> - for having access to the parallel port as "normal" user you have to
>>   tweak probably the udev/hotplug settings depending on the distribution
>>   you use
>> HTH
>> Gerhard
> I switched it to EPP, removed the printer, and voila! I have a scan.
> However, I only got a small scan (not full size of page), and the 
> background is red. I'm trying to scan text to do OCR.
> I tried a full page of text and the background isn't red, but the text 
> is not high enough resolution at all.
> I'll look into getting the it work with Xsane (have to get user to 
> access scanner yet).
> Any tips?
> Crystle

So I ran xsane as root (lots of warnings) and did a higher resolution 
scan and did OCR, and it's decent!

So, I just need to get the scanner allowed by sane for normal users and 
I'm off to the races.

I also have to try to have it work with my printer plugged in, but 
that's not insurmountable.

Thanks everyone for help. I may ask again if I can't get the scanner to 
work outside of root.


Crystle Numan
Administrative Secretary, Immanuel CRC
61 Mohawk Rd. W. Hamilton ON   L9C 1V9
office at immanuelministries.ca

More information about the sane-devel mailing list