[sane-devel] Plustek scanner - follow up

Immanuel CRC Office office at immanuelministries.ca
Fri Aug 4 18:19:38 UTC 2006

Immanuel CRC Office wrote:
> m. allan noah wrote:
>> the permissions of the device file /dev/parport0 need to be changed.
>> in the old days, we would use chmod or chown. if you are still using 
>> kernel 2.4, this might work for you.
>> more modern systems do not have static device files on the hard drive, 
>> the files are created at each boot. so if you make perms changes, they 
>> will be lost at each reboot. there are a myriad of solutions to this, 
>> including hotplug/coldplug, udev, devfs, and resmgr. which one of 
>> those you need depends on which linux you are using, and how recently 
>> it has been updated :(
>> fortunately, it seems that most distros have settled on udev, so 
>> things should hopefully settle down (tongue firmly in cheek)
>> allan
> I'm using Ubuntu 6.06, fully updated. I'll try to find a howto on udev.
> I tried a mini-howto 
> (http://www.linuxprinting.org/download/digitalimage/Scanning-as-Normal-User-on-Wierd-Scanner-Mini-HOWTO.txt) 
> but that was only for /dev/parport0 so that won't work, I guess.
> Crystle

I changed quite a few things, so I don't know if they all need to be 
changed. The last thing I changed that made it work was to add my user 
to the lp group by editing /etc/group and then logging in again.

Other things I changed along the way that might have affected it:

1. Uncommented sane-port in /etc/services

2. Added / edited file sane-port in /etc/xinet.d/
**Restart xinetd after this change**

# default: off
# description: The sane server accepts requests \
# for network access to a local scanner via the \
# network.
service sane
         disable = no
         port            = 6566
         socket_type     = stream
         wait            = no
         groups          = yes
         user            = root
         group           = root
         server          = /usr/sbin/saned

3. added 'localhost' line to /etc/sane.d/saned.conf and /etc/sane.d/net.conf

4. Uncommented 'net' line in /etc/sane.d/dll.conf (near the top)

Anyways, thanks all for the help. I now have to dig to find out how to 
turn off the scanner lamp, as it is tending to stay on.


>> On Fri, 4 Aug 2006, Immanuel CRC Office wrote:
>>> Immanuel CRC Office wrote:
>>>> Gerhard Jaeger wrote:
>>>>> On Thursday 03 August 2006 16:51, Immanuel CRC Office wrote:
>>>>>> Okay, so I'm getting somewhere.
>>>>>> Plustek OpticPro 9639P+, parallel port
>>>>>> using plustek_pp backend.
>>>>>> I have to run all as root so far.
>>>>>> scanimage -L gives:
>>>>>> device `plustek_pp:parport0' is a Plustek 9636P+/Turbo parallel 
>>>>>> port flatbed scanner
>>>>>> device `hpaio:/par/HP_LaserJet_1200?device=/dev/parport0' is a hp 
>>>>>> HP_LaserJet_1200 multi-function peripheral
>>>>>> (Great! I have two connected in series to my parallel port. 
>>>>>> Printer still works. Ideally, I want both connected and both 
>>>>>> working, so we're getting somewhere.)
>>>>>> When I do:
>>>>>> scanimage -d plustek_pp:parport0 -p > image.pnm
>>>>>> I heard a bit of sounds from the scanner. Then I got:
>>>>>> scanimage: sane_read: Error during device I/O
>>>>>> 1. Still can only do stuff as root.
>>>>>> 2. Need to fix error.
>>>>>> Ideas?
>>>>> Hi,
>>>>> I didn't follow the thread so far, so some hints might be doubled:
>>>>> - remove the printer from the chain as this might cause problems
>>>>>   (has also be stated by Plustek)
>>>>> - make sure to have any ECP mode disabled in BIOS (set the port to
>>>>>   SPP, BiDi or EPP)
>>>>> - for having access to the parallel port as "normal" user you have to
>>>>>   tweak probably the udev/hotplug settings depending on the 
>>>>> distribution
>>>>>   you use
>>>>> HTH
>>>>> Gerhard
>>>> I switched it to EPP, removed the printer, and voila! I have a scan.
>>>> However, I only got a small scan (not full size of page), and the 
>>>> background is red. I'm trying to scan text to do OCR.
>>>> I tried a full page of text and the background isn't red, but the 
>>>> text is not high enough resolution at all.
>>>> I'll look into getting the it work with Xsane (have to get user to 
>>>> access scanner yet).
>>>> Any tips?
>>>> Crystle
>>> So I ran xsane as root (lots of warnings) and did a higher resolution 
>>> scan and did OCR, and it's decent!
>>> So, I just need to get the scanner allowed by sane for normal users 
>>> and I'm off to the races.
>>> I also have to try to have it work with my printer plugged in, but 
>>> that's not insurmountable.
>>> Thanks everyone for help. I may ask again if I can't get the scanner 
>>> to work outside of root.
>>> Crystle

Crystle Numan
Administrative Secretary, Immanuel CRC
61 Mohawk Rd. W. Hamilton ON   L9C 1V9
office at immanuelministries.ca

More information about the sane-devel mailing list