[sane-devel] Re: Error when reading from Fujitsu fi-5120c

Wolfram Heider wolframheider at web.de
Thu Aug 24 17:30:05 UTC 2006

On Thu, 24 Aug 2006 16:38:40 +0200, Matthew <ecd at centurytel.net> wrote:

> m. allan noah wrote:
>> what? the other day you were running ubuntu with sane compiled from
>> source, and now you are running suse's resmgr enabled sane rpm?
>> i am confused
>> allan
>> On Wed, 23 Aug 2006, Matthew wrote:
>>> Thanks for the help, but I finally figured it out.
>>> The information I found was located here:
>>> http://support.novell.com/techcenter/sdb/en/2005/09/jsmeix_scanner-setup-100.html
>>> It's for Suse and I'm not sure it will provide much help to anyone not
>>> running suse, but you can always give it a go.
> Sorry about that.  I've been back and forth between Ubuntu and Suse  
> (SLED).
> The story.  I started with Ubuntu because I liked Ubuntu.  However for
> what ever reason I could not get sane to install on Ubuntu.  Was always
> getting this message about libsane.so.1 being locked by ubuntu and
> couldn't be overwritten.  Well, I had access to SLED and having a
> Netware network, I decided to install SLED.  I was able to install sane
> and got it to work once, but I had no TIFF support (don't ask I have
> absolutely no idea what I did).  I tried for a full day to get it to
> work with tiff support, but failed miserably.
> The next day I came in and turned on the computer and all it did was
> restart (found out later that it was because the scanner was on and
> plugged in, a problems now solved as well).  So I reinstalled SLED and
> then proceeded to reinstall the latest version of sane via the source
> code.  This time I got everything working as long as I was in root.  I
> new it was a permission thing, but couldn't figure it out.  I also had
> some other problems and by the end of that day I was so frustrated with
> SLED that I gave up and went back to Ubuntu.
> This time I was able to install sane.  Of course I was having the same
> permission problems as before and I couldn't find anything that helped
> me fix it.  Hence I came here for support.  Of course it took a good day
> to get my question posted here due to permission and what not.  By then
> I was getting so frustrated that I was about to dump Linux and go back
> to Windows only (all over sane).
> In the interim I decide to give SLED one last chance feeling that I was
> never going to get this thing to work.  However I never like to just
> give up.  So I reinstalled SLED and went about setting it all up.  That
> when I found that little page that explained why I couldn't get it to
> work.  Followed those instruction and it all worked flawlessly.  No more
> I/O errors.  No need to be in root.  No more bad boots with the scanner
> turned on.  It all just worked.
> So there it is.  Sorry for the confusion.  When I originally posted the
> question I was back to Ubuntu and would have stayed with Ubuntu, but my
> frustration was pushing me back toward Windows.  If I hadn't decided to
> give SLED one more chance I would be using Windows right now.
> At any rate I do thank you for your help and I do apologize for the
> confusion of my switching back and forth between Ubuntu and SLED.
> Unless something else causes me problems I will be sticking with SLED as
> it integrates well with my Netware and Windows network.
> Matthew

A rather brute method to get things working. But it happens more often  
than one should think. And in many cases without a happy end.
Less persisitant users than Matthew will give up, frustrated switch back  
to windows and that will also be the end of the whole Linux-experiment.

Ironically only a minority of not working scanners is caused by SANE. The  
much bigger portion is due to an improper rights management of the  
underlying distribution. So the question is, if SANE shouldn't come with  
an own installer to set the things right.

Furhermore it could of considerable benefit to have a kind of repository  
within the SANE-website of firmware-files for the scanners which need them  
(driver-CDs invariably tend  to get lost, and a parallel  
windows-installation can't be taken for granted on modern Linux-boxes any  

Btw even under XP by far not all scanners behave as they shall do -  
especially MFDs and ADF-scanner malfunction up to a total failure in  
considerable numbers. But then you are really running on empty since there  
is nothing comparable as the excellent SANE-documentation or a highly  
qualified mailing-list like this one.

Wolfram Heider

More information about the sane-devel mailing list