[sane-devel] usblp trouble with all-in-one device

Olaf Meeuwissen olaf.meeuwissen at avasys.jp
Fri Dec 15 08:27:47 CET 2006

Hi everyone,

Working on support for a new business oriented all-in-one for iscan, I
have hit a dead end and would appreciate some insights/suggestions.

When attaching the device, the kernel loads the usblp module and CUPS
has no trouble finding the printer part.  On the scanner side however,
the device is (usually) found but I can't get it to scan.  Looking at
the debugging info, this is what happens:

  # SANE frontend is started
  device is opened
  backend sends a reset
  device acknowledges
  backend queries for some status info
  device replies with status info
  device is closed
  # request preview via frontend
  device is opened
  backend sends a reset
  device does not acknowledge within timeout period (60 seconds)

FYI, 60 seconds is plenty time to reset the device and acknowledge the
reset, so I am at a loss why I'm not getting acknowledged.  Without it
the backends signals an I/O error and correctly refuses to continue.
# Repeated requests for a preview also do not get acknowledged

Aware of trouble in the past[1][2], I power cycled the device, rmmod'd
usblp and tried again.  When doing this, I have absolutely no trouble
scanning whatsoever but now CUPS no longer sees the printer part.

Considering the target audience for this device, I can't very well say
"Oh, just rmmod usblp before you scan and insmod usblp again when you
are done".  Similarly, suggesting to compile a CUPS usb backend using
usb-libusb.c[1] is also not particularly user friendly.
# Besides I haven't checked (yet) whether that (still) works.

Is there a way to get SANE, CUPS and usblp to play nice _together_?
I'd sure like to know.

FWIW, I've tried this on Debian GNU/Linux testing/unstable development
machine (up-to-date as of 2006-12-14 with a 2.6.18 kernel) and a stock
workstation FC3 install.

[1] http://lists.alioth.debian.org/pipermail/sane-devel/2005-September/014721.html
[2] http://bugzilla.kernel.org/show_bug.cgi?id=5001
[3] https://alioth.debian.org/tracker/index.php?func=detail&aid=302207&group_id=30186&atid=410366
Olaf Meeuwissen                          EPSON AVASYS Corporation, SE1
FSF Associate Member #1962           sign up at http://member.fsf.org/
GnuPG key: 6BE37D90/AB6B 0D1F 99E7 1BF5 EB97  976A 16C7 F27D 6BE3 7D90
Penguin's lib!       -- I hack, therefore I am --               LPIC-2

More information about the sane-devel mailing list