[sane-devel] Umax 2000P

Frank McCormick fmccormick at videotron.ca
Sat Dec 30 23:02:45 CET 2006

Hello all

    I am trying to get a Umax 2000p scanner to work with my Ubuntu installation. So far no luck - I keep getting
an error message which seems to indicate the SANE frontend or maybe the backends were not compiled with an option.

This is the error:

frank at ubuntu:~$ xsane
[umax_pp_low] sanei_umax_pp_InitPort cannot use direct hardware access
[umax_pp_low] if not compiled with --enable-parport-directio

In googling the problem it seems there are 2 ways of accessing the parallel port directly or through ppdev. However when I load that module (sudo modprobe ppdev) I am no further ahead.

I also tried downloading the sources and compiling but when it came to compiling the front end it failed because it seems to think the backends have not been compiled, when in fact they have been. I am using Ubuntu Dapper and Edgy but both distributions give me the same error. Is it possible to use a Debian distros files ? Is there any other way to resolve this ?


-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
Url : http://lists.alioth.debian.org/pipermail/sane-devel/attachments/20061230/6db005ba/attachment.pgp

More information about the sane-devel mailing list