[sane-devel] help with Canon 650U

Henning Meier-Geinitz henning at meier-geinitz.de
Sun Feb 26 12:07:21 UTC 2006


On 2006-02-21 17:19, void at chatcircuit.com wrote:
> I am having issues getting my Canon 650U scanner to work. I have followed the
> following walkthrough online
> (http://gentoo-wiki.com/HOWTO_Installing_USB_Scanner) but still, I do not have
> a scanner that detects in xsane.

For testing, using the command line tool "scanimage -L" as root may be

> When I run sane-find-scanner it detects the
> Canon 650U scanner using libusb. but xsane does not see this scanner, instead
> it only sees my tv-in card(ATI TV Wonder VE) I made sure plustek was commented
> out in dll.conf. I tried rm -rf /root/.xsane.

If you comment out "plustek" in dll.conf you disable support for your
scanner. It's quite ok that it isn't found in this case.

> I was curious, do I need to enable USB scanner support in the kernel?

It must be enabled in the kernel. But if you haven't done any manual
configuration USB support will be turned on in kernels provided by

> I'm pretty
> sure I don't need to since libusb seems to be working fine, and when I'm using
> my knoppix CD the scanner module isn't loaded.

You don't need the kernel scanner module (in fact, it doesn't exist
any more with recent kernels).

> Just double checking. As well,
> I'm using udev. I have checked to see if I do have a locked directory, which I
> do. I've been trying to get this to work for a while. I know it isn't a
> hardware problem, considering I have a knoppix CD that detects the scanner, and
> lets me use it in xsane. I'm sorry for the lack of logs, I don't have the
> internet at home. I'm pretty sure it's a configuring problem, which I need help
> figuring out. If I am slow at responding, sorry, I'm only able to use the
> library on Tuesdays and Thursdays.

We need a log file. Maybe you can find out the reason yourself by
looking at it:

SANE_DEBUG_PLUSTEK=255 scanimage -L


More information about the sane-devel mailing list