[sane-devel] help with Canon 650U

void at chatcircuit.com void at chatcircuit.com
Tue Feb 21 17:19:37 UTC 2006

I am having issues getting my Canon 650U scanner to work. I have followed the
following walkthrough online
(http://gentoo-wiki.com/HOWTO_Installing_USB_Scanner) but still, I do not have
a scanner that detects in xsane. When I run sane-find-scanner it detects the
Canon 650U scanner using libusb. but xsane does not see this scanner, instead
it only sees my tv-in card(ATI TV Wonder VE) I made sure plustek was commented
out in dll.conf. I tried rm -rf /root/.xsane.

I was curious, do I need to enable USB scanner support in the kernel? I'm pretty
sure I don't need to since libusb seems to be working fine, and when I'm using
my knoppix CD the scanner module isn't loaded. Just double checking. As well,
I'm using udev. I have checked to see if I do have a locked directory, which I
do. I've been trying to get this to work for a while. I know it isn't a
hardware problem, considering I have a knoppix CD that detects the scanner, and
lets me use it in xsane. I'm sorry for the lack of logs, I don't have the
internet at home. I'm pretty sure it's a configuring problem, which I need help
figuring out. If I am slow at responding, sorry, I'm only able to use the
library on Tuesdays and Thursdays.

Thanks for your help,

More information about the sane-devel mailing list