[sane-devel] Problem scanning with Samsung scx-4100 on centos 4.2

Henning Meier-Geinitz henning at meier-geinitz.de
Mon Mar 6 20:02:23 UTC 2006


On 2006-02-27 11:16, Prajjwal Devkota wrote:
> I have unsuccessfully been trying to get a Samsung scx-4100 to scan
> using my linux machines for quite some time.  I have tried using both
> fedora core 3 (various kernels), and centos 4.2 (kernel 2.6.9), but
> scanimage segfaults when I try to scan.  I noticed a similar post on
> this list
> (http://lists.alioth.debian.org/pipermail/sane-devel/2005-May/013660.html), but the problem seems to be a bit different than mine.  I also had a look at (http://hathawaymix.org/Weblog/2005-07-15), and copied the files as recommended, but could not get the scanner detected by sane-find-scanner.  I tried installing the rpm (rebuilt from source) from (http://oskari.saarenmaa.fi/rpm/), but that gave the same problem: scanimage segfaulting.  I am still looking for a way to get the scanner working on my fileserver, and would like any help or pointers you may give to point me in the right direction.

The samsung backends are binary-only code, if I remember correctly. So
only the author (Samsung) can really help because nobody here can look
at the source code for debugging.

However, there are some positive reports about this scanner, e.g. in
our bug reporting system:

> [prajjwald at ictfserver ~]$ scanimage >image.pnm
> scanimage: WARNING: read more data than announced by backend (26083328/26071038)

Most probably this is a backend bug. Tell Samsung about it.

More information about the sane-devel mailing list