[sane-devel] problem with Epson perfection 2480 photo scanner in FreeBSD

breach0r breacher at telenet.be
Sat Mar 18 14:06:35 UTC 2006

Hi all,

I have a major issue with my Epson perfection 2480 photo scanner. It used to 
run in FreeBSD. I haven't used it in a few weeks during which upgrades 
occured and I noticed this week it stopped working. Portupgrade of sane had 
replaced the snapscan.conf file, I put back there my correct firmware file 
with full pathname but it still doesn't work.

Since I track 5.4/5-STABLE, I first reverted to 5.4-RELEASE. When the scanner 
worked, it used to be initialised at boot time (makes the double noise) but 
even after the downgrade it wasn't. I also downgraded Xsane to 0.98 but it 
didn't help either. I don't have any older tar of sane-backends in distfiles 
and didn't delete those for a long time, so I haven't tried downgrading 
backends. I don't understand. Usual errors are either "No device available" 
or :

Failed to open device 'snapscan:libusb:/dev/usb1:/dev/ugen0': Error during 
device I/O.

It isn't a permission problem since I'm trying to fix this as root.

The kernel, however, sees the scanner when it connects:

dmesg |grep EPSON
ugen0: EPSON EPSON Scanner, rev 2.00/1.10, addr 2

I may be mistaken but may be the system used to see the scanner as uscanner0 
or something back when it used to work.

When I reset the scanner (unplug the power chord), the ready light is green, 
until the system tries to initalise it, at which point it turns off (pale 

Please can anyone else who experienced similar problems or who is using this 
scanner in FreeBSD provide usable input? Thanks a lot.

More information about the sane-devel mailing list