[sane-devel] problem with Epson perfection 2480 photo scanner in FreeBSD

Oliver Schwartz Oliver.Schwartz at gmx.de
Sun Mar 19 17:51:52 UTC 2006


> I have a major issue with my Epson perfection 2480 photo scanner.
> It used to run in FreeBSD. I haven't used it in a few weeks during
> which upgrades occured and I noticed this week it stopped working.
> Portupgrade of sane had replaced the snapscan.conf file, I put back
> there my correct firmware file with full pathname but it still
> doesn't work.
> Since I track 5.4/5-STABLE, I first reverted to 5.4-RELEASE. When
> the scanner worked, it used to be initialised at boot time (makes
> the double noise) but even after the downgrade it wasn't. I also
> downgraded Xsane to 0.98 but it didn't help either. I don't have
> any older tar of sane-backends in distfiles and didn't delete those
> for a long time, so I haven't tried downgrading backends. I don't
> understand. Usual errors are either "No device available" or :
> Failed to open device 'snapscan:libusb:/dev/usb1:/dev/ugen0': Error
> during device I/O.

The debug log may provide more hints on what's going wrong. Can you 
try to set the environment variable SANE_DEBUG_SNAPSCAN=255, 
reproduce the error and post the debug log?


More information about the sane-devel mailing list