[sane-devel] CanoScan LiDE 25 found by sane-find-scanner but not scanimage

Wolfram Heider wolframheider at web.de
Sun Sep 3 22:37:51 UTC 2006


>> On Sat, 02 Sep 2006 00:40:42 +0200, Warren Post
>> <warren at copaninvest.com> wrote:
> [snip]
>> > 3. Modified /etc/sane.d/plustek.conf per man sane-plustek.
>> > Specifically, I added the line "[usb] 0x04a9 0x2220". I have tried
>> > both "device auto" and not having a device line.
>> the entry should read "device /dev/usbscanner"
> Thanks, Wolfram. Just tried that; no change -- probably because I have
> no file /dev/usbscanner. But isn't /dev/usbscanner only to access a USB
> scanner via a module? I am using libusb, and if I am reading the docs
> right libusb users should not have any scanner modules loaded. A
> comment in plustek.conf says:
> # ...if... you use libusb, simply set vendor- and product-ID
> # [usb] 0x07B3 0x0017
> # device auto
> If I am wrong I can certainly create /dev/usbscanner as a symlink, but
> if so, what should I point it to?
>> I'm not familiar with Mandriva. If there exists a usb.usermap in
>> /etc/hotplug it should be modified due to
>> /usr/share/doc/packages/sane/sane-backends/plustek/Plustek-USB.txt.
> There is no file named usb.usermap on my system anywhere,
> and /etc/hotplug contains only blacklist and device-specific usermap
> files. So I created one, adding the line specified by
> Plustek-USB.txt. Ditto /etc/hotplug/usb/usbscanner. Same result,
> however.
> Plustek-USB.txt also instructs me to append the line "scanner"
> to /etc/hotplug/blacklist, but that file is data, not text:
> [warren at gerencia ~]$ file /etc/hotplug/blacklist
> /etc/hotplug/blacklist: data
> ...so I am not sure how to edit it. With hexedit, perhaps?
won't be necessary, see below.
>> Last not least the plustek-entry in /etc/sane.d/dll.conf should be
>> uncommented.
> Done.
>> Additionally you should make sure that the scanner.o module isn't
>> loaded...
> Done: "lsmod | grep scanner" comes up empty.
o.k. If no scanner-module is loaded there is no need for further
configuration with blacklists.
>> ...and that possible remnants of the prior sane-installation
>> are removed completely.
> This should have been done by rpm when I upgraded from
> sane-backends-1.0.16 to 1.0.17. However, "locate 1.0.16"
> immediately after running updatedb turns up suspicious
> files: /usr/lib/sane/libsane-backend_name.so.1.0.16, one for each
> backend, and /usr/lib/libsane.so.1.0.16. There are no corresponding
> 1.0.17 files. The file lists for the rpms for both versions show no
> such files, so I'm not sure where they came from.

If I get you right, you installed the new SANE over the existing one
(windows-style).. However, it's strongly recommended to wipe out a earlier
SANE-installation cleanly from the harddrive before installing a new
version. Either with 'rpm --erase=sane1.0.16.rpm', or 'make uninstall' or
with the setup-program of your distri, depending on the kind of the
original installation. You mentioned, you've done the installation with
rpm, so it would be the first option.
> I have to wonder if this is related to what I noted in my original
> post, which is that sane-plustek checks for other Canon scanners (all
> those supported by 1.0.16, I have since confirmed) but not my scanner
> (support for which was added in 1.0.17).
The Canon Lide 25 should cause no problems with SANE. And it seems your
SANE-installation isn't really clean. So I would remove the whole
SANE-stuff completely and do a entirely fresh setup. Try the first scan as

Wolfram Heider

More information about the sane-devel mailing list