[sane-devel] Epson 2450 found by sane-find-scanner but not by scanimage

Tom Mitchell trmitchell at hotmail.co.uk
Tue Sep 19 16:26:43 UTC 2006

I am using an Asrock dual sata motherboard with AMD939 64 processor and 
sataII drive. I have installed PClinuxos minime0.93a a Mandriva based system 
  on to a clean partion. I have also installed an Epson r220 usb printer 
which works really well.
The Distro uses
xsane 0.991_2tex
sane-backends  1.0.18-1tex
libusb         1.0.18-1tex
kernel is for i686
kde version 3.5.3

I am unable to get the scanner to work.
It has worked before with Xandros3.0.2 and does with the simplymepis6 
livecd. So I know that the cables etc are ok.

When booted with the scanner on

sane-find-scanner results in
found USB scanner (vendor=0x04b8 [EPSON], product=0x0112 [EPSON Scanner]) at 
  # Your USB scanner was (probably) detected. It may or may not be supported 
  # SANE. Try scanimage -L and read the backend's manpage.

scanimage -L
No scanners were identified. If you were expecting something different,
check that the scanner is plugged in, turned on and detected by the
sane-find-scanner tool (if appropriate). Please read the documentation
which came with this software (README, FAQ, manpages).

this is both as root and as normal user.

I have tried specifying the usb vendor and device in the epson.conf and 
epkowa.conf files in /etc/sane.d

I have also modified /etc/udev/rules.d/70-libsane.rules

ACTION!="add", GOTO="libsane_rules_end"
SUBSYSTEM!="usb_device", GOTO="libsane_rules_end"
as suggested for Iscan at


ACTION!="add", GOTO="libsane_rules_end"
SUBSYSTEM!="usb", GOTO="libsane_rules_end"

but this doesnt work.

#lsusb states
Bus 004 Device 004: ID 04b8:0112 Seiko Epson Corp. Perfection 2450
Bus 004 Device 001: ID 0000:0000
Bus 003 Device 001: ID 0000:0000
Bus 002 Device 001: ID 0000:0000
Bus 001 Device 003: ID 03f0:050c Hewlett-Packard 5219 Wireless Keyboard
Bus 001 Device 001: ID 0000:0000

If I switch the scanner off and on I then get

# scanimage -L
device `epkowa:libusb:004:005' is a Epson Perfection 2450 flatbed scanner
# scanimage >image.pnm
scanimage: no SANE devices found

Whatever I try I cant seem to get to see the device. I would be grateful for 
any help to resolve this.
Similar problems exist with Xandros4.0

Be the first to hear what's new at MSN - sign up to our free newsletters! 

More information about the sane-devel mailing list