[sane-devel] Epson 2450 found by sane-find-scanner but not by scanimage

Olaf Meeuwissen olaf.meeuwissen at avasys.jp
Thu Sep 21 23:31:03 UTC 2006

"Tom Mitchell" <trmitchell at hotmail.co.uk> writes:

> Hi,
> I am using an Asrock dual sata motherboard with AMD939 64 processor
> and sataII drive. I have installed PClinuxos minime0.93a a Mandriva
> based system on to a clean partion. I have also installed an Epson
> r220 usb printer which works really well.
> The Distro uses
> xsane 0.991_2tex
> sane-backends  1.0.18-1tex
> libusb         1.0.18-1tex
> kernel is for i686
> kde version 3.5.3
> I am unable to get the scanner to work.
> It has worked before with Xandros3.0.2 and does with the simplymepis6
> livecd. So I know that the cables etc are ok.
> When booted with the scanner on
> sane-find-scanner results in
> found USB scanner (vendor=0x04b8 [EPSON], product=0x0112 [EPSON
> Scanner]) at libusb:004:004
>  # Your USB scanner was (probably) detected. It may or may not be
> supported by
>  # SANE. Try scanimage -L and read the backend's manpage.
> scanimage -L
> No scanners were identified. If you were expecting something different,
> check that the scanner is plugged in, turned on and detected by the
> sane-find-scanner tool (if appropriate). Please read the documentation
> which came with this software (README, FAQ, manpages).
> this is both as root and as normal user.
> I have tried specifying the usb vendor and device in the epson.conf
> and epkowa.conf files in /etc/sane.d

That is not necessary for either backend.

> I have also modified /etc/udev/rules.d/70-libsane.rules
> ACTION!="add", GOTO="libsane_rules_end"
> SUBSYSTEM!="usb_device", GOTO="libsane_rules_end"
> as suggested for Iscan at
> http://www.avasys.jp/english/linux_e/faq_scan.html
> ACTION!="add", GOTO="libsane_rules_end"
> SUBSYSTEM!="usb", GOTO="libsane_rules_end"
> but this doesnt work.

Do NOT change the *libsane.rules file.  Your distribution should have
done the right thing.  This change is only needed for *iscan.rules and
then only on those distributions that do not use "usb_device" for the
udev SUBSYSTEM name.  So far, we know about Mandriva 2006.0.

BTW, this will be fixed in the next iscan release.

> #lsusb states
> Bus 004 Device 004: ID 04b8:0112 Seiko Epson Corp. Perfection 2450
> Bus 004 Device 001: ID 0000:0000
> Bus 003 Device 001: ID 0000:0000
> Bus 002 Device 001: ID 0000:0000
> Bus 001 Device 003: ID 03f0:050c Hewlett-Packard 5219 Wireless Keyboard
> Bus 001 Device 001: ID 0000:0000
> If I switch the scanner off and on I then get
> # scanimage -L
> device `epkowa:libusb:004:005' is a Epson Perfection 2450 flatbed scanner
> # scanimage >image.pnm
> scanimage: no SANE devices found

Do you have the epson backend disabled in /etc/sane.d/dll.conf?  I'd
expect to see `epson:libusb:004:005' listed in the scanimage -L output
as well.

Can you provide debugging output?  The following command will put the
debugging output in epkowa.log.

  SANE_DEBUG_EPKOWA=127 scanimage > image.pnm 2> epkowa.log

> Whatever I try I cant seem to get to see the device. I would be
> grateful for any help to resolve this.
> Similar problems exist with Xandros4.0

Hope this helps,
Olaf Meeuwissen                          EPSON AVASYS Corporation, SE1
FSF Associate Member #1962           sign up at http://member.fsf.org/
GnuPG key: 6BE37D90/AB6B 0D1F 99E7 1BF5 EB97  976A 16C7 F27D 6BE3 7D90
Penguin's lib!       -- I hack, therefore I am --               LPIC-2

More information about the sane-devel mailing list