[sane-devel] Epson 2450 found by sane-find-scanner but not by scanimage

Tom Mitchell trmitchell at hotmail.co.uk
Sun Sep 24 21:45:18 UTC 2006

Hi Olaf,
Sorry for the delay in replying I appreciate your help.

1)I have put all files back to their originals.

2)You asked

"Do you have the epson backend disabled in /etc/sane.d/dll.conf?  I'd
expect to see `epson:libusb:004:005' listed in the scanimage -L output
as well."

I didnt have the backend disabled. Both lines do not have an # in front of 

3) I have tried to run  as user and got permission denied.

4) As root the output of SANE_DEBUG_EPKOWA=127 scanimage > image.pnm 2> 


[sanei_debug] Setting debug level of epkowa to 127.
[epkowa] sane_init: iscan 2.1.0
[epkowa] sane_init, ># epkowa.conf -- sample configuration for the EPKOWA 
SANE backend<
[epkowa] sane_init, ># Copyright (C) 2004  Olaf Meeuwissen<
[epkowa] sane_init, >#<
[epkowa] sane_init, ># See sane-epkowa(5), sane-scsi(5) and sane-usb(5) for 
[epkowa] sane_init, ><
[epkowa] sane_init, ># SCSI scanners can be configured simply by listing the 
path to the<
[epkowa] sane_init, ># device.  For example, if your system claims to have a 
[epkowa] sane_init, ># SCSI device, all you have to do is uncomment the 
following line:<
[epkowa] sane_init, >#<
[epkowa] sane_init, >#/dev/scanner<
[epkowa] sane_init, >#<
[epkowa] sane_init, ># In the interest of maintainability, most 
installations would have<
[epkowa] sane_init, ># /dev/scanner sym-linked to the real SCSI scanner 
device node.<
[epkowa] sane_init, >#<
[epkowa] sane_init, ># An alternative way that works for many operating 
systems and is a<
[epkowa] sane_init, ># little bit more generic, is to have the backend probe 
for your SCSI<
[epkowa] sane_init, ># scanner with the following configuration command:<
[epkowa] sane_init, >#<
[epkowa] sane_init, >scsi EPSON<
[epkowa] sane_init, ><
[epkowa] sane_init, ># On systems with libusb, the following line is 
sufficient to get the<
[epkowa] sane_init, ># backend to recognise your USB scanners.  It presumes, 
however, that<
[epkowa] sane_init, ># the scanner---more precisely, it's USB product 
ID---is known to the<
[epkowa] sane_init, ># backend.<
[epkowa] sane_init, ># For all USB scanners that are officially supported by 
this backend,<
[epkowa] sane_init, ># this presumption is true.  A list of such scanners 
can be found in<
[epkowa] sane_init, ># sane-epkowa(5).<
[epkowa] sane_init, >#<
[epkowa] sane_init, >usb<
[epkowa] attach_one_usb()
[epkowa] EPKOWA SANE Backend 2.1.0 - 2006-05-22
[epkowa] attach(, 3)
[epkowa] attach: opening
[epkowa] attach_one_usb(libusb:004:004)
[epkowa] EPKOWA SANE Backend 2.1.0 - 2006-05-22
[epkowa] attach(libusb:004:004, 3)
[epkowa] attach: opening libusb:004:004
[epkowa] Found valid EPSON scanner: 0x4b8/0x112 (vendorID/productID)
[epkowa] reset()
[epkowa] send buf, size = 2
[epkowa] buf[0] 1b .
[epkowa] buf[1] 40 @
[epkowa] receive buf, expected = 1, got = 0
[epkowa] get_identity_information()
[epkowa] send buf, size = 2
[epkowa] buf[0] 1b .
[epkowa] buf[1] 49 I
[epkowa] receive buf, expected = 4, got = 0
[epkowa] ident failed
[epkowa] close_scanner(fd = 0)
[epkowa] sane_init, ><
[epkowa] sane_init, ># For any USB scanner not known to the backend (yet), 
you may, at your<
[epkowa] sane_init, ># own peril(!!), force the backend to recognise and use 
it via libusb.<
[epkowa] sane_init, ># You can do so by the following configuration 
[epkowa] sane_init, >#<
[epkowa] sane_init, >#   usb <USB vendor ID> <USB product ID><
[epkowa] sane_init, >#<
[epkowa] sane_init, ># SEIKO EPSON's USB vendor ID is '0x04b8' (without 
quotes).  In order<
[epkowa] sane_init, ># to find the USB product ID, use lsusb(1) or, on Linux 
systems, peek<
[epkowa] sane_init, ># at the information in /proc/bus/usb/devices.<
[epkowa] sane_init, ># A sample configuration for the Perfection 1650 
(GT-8200), which has<
[epkowa] sane_init, ># a product ID of 0x0110, would look as follows:<
[epkowa] sane_init, >#<
[epkowa] sane_init, >#usb 0x04b8 0x0110<
[epkowa] sane_init, ><
[epkowa] sane_init, ># When not accessing your USB scanner via libusb, you 
may need to use<
[epkowa] sane_init, ># one of the configuration commands below or commands 
that are almost<
[epkowa] sane_init, ># the same.  These commands typically access the 
scanner via a kernel<
[epkowa] sane_init, ># scanner module.<
[epkowa] sane_init, >#<
[epkowa] sane_init, >#usb /dev/usb/scanner0<
[epkowa] sane_init, >#usb /dev/usbscanner0<
[epkowa] sane_init, >#usb /dev/uscanner0<
[epkowa] sane_init, >#<
[epkowa] sane_init, ># Linux had a scanner module until version 2.6.2.  As 
of version 2.6.3<
[epkowa] sane_init, ># libusb is your only option.  Linux' scanner module 
can be loaded via<
[epkowa] sane_init, ># the modprobe(8) command like so:<
[epkowa] sane_init, >#<
[epkowa] sane_init, >#   modprobe scanner vendor=<USB vendor ID> 
product=<USB product ID><
[epkowa] sane_init, >#<
[epkowa] sane_init, ># If the scanner module already knows the vendor and 
product IDs, you<
[epkowa] sane_init, ># do not have to specify them.  If you want to have 
this done automa-<
[epkowa] sane_init, ># tically every time you boot, you can add the above 
line, except for<
[epkowa] sane_init, ># the modprobe command itself, to your /etc/modules 
[epkowa] sane_init, ><
[epkowa] sane_init, ># Although not tested with this backend, parallel port 
scanners should<
[epkowa] sane_init, ># be usable.  You can configure them as shown below, 
but I do not know<
[epkowa] sane_init, ># much about the details.  Information is welcome.<
[epkowa] sane_init, >#<
[epkowa] sane_init, >#pio 0x278<
[epkowa] sane_init, >#pio 0x378<
[epkowa] sane_init, >#pio 0x3BC<
[epkowa] sane_get_devices()
scanimage: no SANE devices found
[epkowa] sane_exit

Hope thia helps

SANE_DEBUG_EPKOWA=127 scanimage > image.pnm 2> epkowa.log
>From: Olaf Meeuwissen <olaf.meeuwissen at avasys.jp>
>To: "Tom Mitchell" <trmitchell at hotmail.co.uk>
>CC: sane-devel at lists.alioth.debian.org
>Subject: Re: [sane-devel] Epson 2450 found by sane-find-scanner but not by 
>Date: Fri, 22 Sep 2006 08:31:03 +0900
>"Tom Mitchell" <trmitchell at hotmail.co.uk> writes:
> > Hi,
> > I am using an Asrock dual sata motherboard with AMD939 64 processor
> > and sataII drive. I have installed PClinuxos minime0.93a a Mandriva
> > based system on to a clean partion. I have also installed an Epson
> > r220 usb printer which works really well.
> > The Distro uses
> > xsane 0.991_2tex
> > sane-backends  1.0.18-1tex
> > libusb         1.0.18-1tex
> > kernel is for i686
> > kde version 3.5.3
> >
> > I am unable to get the scanner to work.
> > It has worked before with Xandros3.0.2 and does with the simplymepis6
> > livecd. So I know that the cables etc are ok.
> >
> > When booted with the scanner on
> >
> > sane-find-scanner results in
> > found USB scanner (vendor=0x04b8 [EPSON], product=0x0112 [EPSON
> > Scanner]) at libusb:004:004
> >  # Your USB scanner was (probably) detected. It may or may not be
> > supported by
> >  # SANE. Try scanimage -L and read the backend's manpage.
> >
> > scanimage -L
> > No scanners were identified. If you were expecting something different,
> > check that the scanner is plugged in, turned on and detected by the
> > sane-find-scanner tool (if appropriate). Please read the documentation
> > which came with this software (README, FAQ, manpages).
> >
> > this is both as root and as normal user.
> >
> > I have tried specifying the usb vendor and device in the epson.conf
> > and epkowa.conf files in /etc/sane.d
>That is not necessary for either backend.
> > I have also modified /etc/udev/rules.d/70-libsane.rules
> >
> > ACTION!="add", GOTO="libsane_rules_end"
> > SUBSYSTEM!="usb_device", GOTO="libsane_rules_end"
> > as suggested for Iscan at
> >
> > http://www.avasys.jp/english/linux_e/faq_scan.html
> >
> > ACTION!="add", GOTO="libsane_rules_end"
> > SUBSYSTEM!="usb", GOTO="libsane_rules_end"
> >
> > but this doesnt work.
>Do NOT change the *libsane.rules file.  Your distribution should have
>done the right thing.  This change is only needed for *iscan.rules and
>then only on those distributions that do not use "usb_device" for the
>udev SUBSYSTEM name.  So far, we know about Mandriva 2006.0.
>BTW, this will be fixed in the next iscan release.
> > #lsusb states
> > Bus 004 Device 004: ID 04b8:0112 Seiko Epson Corp. Perfection 2450
> > Bus 004 Device 001: ID 0000:0000
> > Bus 003 Device 001: ID 0000:0000
> > Bus 002 Device 001: ID 0000:0000
> > Bus 001 Device 003: ID 03f0:050c Hewlett-Packard 5219 Wireless Keyboard
> > Bus 001 Device 001: ID 0000:0000
> >
> >
> > If I switch the scanner off and on I then get
> >
> > # scanimage -L
> > device `epkowa:libusb:004:005' is a Epson Perfection 2450 flatbed 
> > # scanimage >image.pnm
> > scanimage: no SANE devices found
>Do you have the epson backend disabled in /etc/sane.d/dll.conf?  I'd
>expect to see `epson:libusb:004:005' listed in the scanimage -L output
>as well.
>Can you provide debugging output?  The following command will put the
>debugging output in epkowa.log.
>   SANE_DEBUG_EPKOWA=127 scanimage > image.pnm 2> epkowa.log
> > Whatever I try I cant seem to get to see the device. I would be
> > grateful for any help to resolve this.
> > Similar problems exist with Xandros4.0
>Hope this helps,
>Olaf Meeuwissen                          EPSON AVASYS Corporation, SE1
>FSF Associate Member #1962           sign up at http://member.fsf.org/
>GnuPG key: 6BE37D90/AB6B 0D1F 99E7 1BF5 EB97  976A 16C7 F27D 6BE3 7D90
>Penguin's lib!       -- I hack, therefore I am --               LPIC-2

Windows Live™ Messenger has arrived. Click here to download it for free! 

More information about the sane-devel mailing list