[sane-devel] HP ScanJet 7400c on Mac OS X (TWAIN-SANE interface v. 2.0, sane-avision backend)

Moritz Heckscher moritz.heckscher at gmx.de
Tue Aug 7 13:45:41 UTC 2007


on the SANE homepage, I saw that the HP ScanJet 7400c is supported by  
the avision backend *in build 201* (or above, I assume).

Now, how do I find out which build I have?

I still haven't resolved the issue, the scanner is basically unusable  
on the machine since it is unpredictable when it will work and when  
it won't. So if you have any tips for me, please let me know. I don't  
think I have an outdated build, but I am holding onto every straw I  
can find...


Am 05.08.2007 um 18:07 schrieb Moritz Heckscher:

> Hi all,
> I'm trying to get a HP ScanJet 7400c to work on a Mac OS X platform  
> using SANE as provided by Matthias Ellert's TWAIN-SANE packages,  
> and I'm having some problems.
> Do others also have problems with this particular scanner (not  
> necessarily on Mac OS X), or does it usually work fine?
> The SANE backend I'm using is the newest (1.0.18). The OS  
> recognises the scanner correctly on the USB port.
> "sane-find-scanner" usually detects the scanner correctly:
>> found USB scanner (vendor=0x03f0 [hp], product=0x0801 [hp scanjet  
>> 7400c]) at libusb:002:002-03f0-0801-00-00
> I say usually because sometimes it doesn't. I haven't figured out a  
> pattern, but I believe it takes a few minutes after plugging in for  
> the scanner to be recognised (although its display indicates long  
> before that it is ready). Either that or I need to unplug and  
> replug the power and USB connection. As I said, I haven't found a  
> pattern.
> "scanimage -L", however, takes very long (almost a minute), and  
> also doesn't always successfully find the scanner. I've enabled  
> debugging output with "export SANE_DEBUG_AVISION=7" in the shell.  
> In a succesful procedure, the scanner seems to be recognised almost  
> immediately:
>> [avision] attach: Inquiry gives mfg=hp, model=scanjet 7400c,  
>> product revision=0.8S.
> A lot of communication then follows between the scanner and the PC.  
> This takes very long, as described above, and finally ends with (in  
> a succesful case):
>> [avision] sane_get_devices:
>> device `avision:libusb:002:002-03f0-0801-00-00' is a Hewlett- 
>> Packard ScanJet 7400c flatbed scanner
>> [avision] sane_exit:
> I'm attaching the complete log for a succesful case to this message  
> (HP7400c-succesful.txt).
> So my question is: Is it normal for "scanimage -L" to take this  
> long? I've used another scanner with the gt68xx backend before, and  
> there the command worked almost instantaneously. And is it normal  
> for the command to sometimes work and sometimes fail (although  
> "sane-find-scanner" has detected the scanner)?
> In cases when it doesn't work (although "sane-find-scanner" has  
> detected the scanner), there seems to be a problem with attaching:
>> [avision] sane_init: config file line 24: trying to attach  
>> USB:`usb 0x03f0 0x0801'
>> [avision] attach:
>> [avision] attach: opening libusb:002:002-03f0-0801-00-00
>> [avision] attach: open failed (Invalid argument)
> I'm attaching the complete log for an unsuccesful case as well  
> (HP7400c-unsuccesful.txt).
> Once the scanner is found by "scanimage -L", I still have problems.  
> Usually I can scan from the command line with "scanimage", but I  
> can't in GUI applications. Usually the GUI just hangs and doesn't  
> react.
> I've debugged the TWAIN-SANE interface (version 2.0) a bit and have  
> found the problem to occur in line 832:
>> /tmp/TWAIN-SANE-Interface.build/SaneDevice.cpp:832: failed  
>> assertion `status == SANE_STATUS_GOOD'
> I've successfully used the scanner *once* in "Image Capture.app",  
> in all other cases it failed, and it never worked in "Graphic  
> Converter.app".
> My initial guess was that the problem could be the long delay  
> described above. But maybe it's a problem in the TWAIN-SANE  
> interface with getting some options of the scanner (buttons? ADF?)  
> to work? Unfortunately, my debugging capabilities aren't that  
> great, so I couldn't track this further.
> Any help is highly appreciated!
> -Moritz
> P.S.: I intend to give it a try in a few days on a machine with  
> Ubuntu once I have access.
> <HP7400c-succesful.txt>
> <HP7400c-unsuccesful.txt>

More information about the sane-devel mailing list